PyCharm 2021 professional - Can't add interpreter...

So, I've been shown to click CTRL ALT S. I should have the ability to add a Python Interpreter there. After that I'd like to import packages. Here's what I see. Apparently, there is "Nothing to show", and no button to add an interpreter, no way to configure, and no configuration of interpreters in the status bar:

I really am trying to follow instructions through research. But when I follow those instructions and consistently see screenshots that look nothing like mine I'm hoping someone here can help.

 

5 comments
Comment actions Permalink

Hello,

The behavior is under investigation now, please follow https://youtrack.jetbrains.com/issue/PY-48492

A workaround is to delete .idea folder in the project and reopen it in PyCharm.

1
Comment actions Permalink

Many thanks!

Yes, I zipped the .idea folder for archive, deleted it, restarted PyCharm, and an installer was installed.

0
Comment actions Permalink

Carewen Could you please share your zipped .idea folder in PY-48492 (or create a new private issue in our bug tracker if necessary)? It may help us to investigate the problem quicker.

0
Comment actions Permalink

Having same issue, if this is a known issue... why don't you create a little script that does this for us?

"Hello Human, for some reason I can't find the interpreter, my genius creators do have an option we could adjust the .idea file and restart" Yes No

See how that helps solve the problem and we don't fill up existing "known issue" boards with duplicate problems?

0

Please sign in to leave a comment.