Cannot resolve language with id ''go''

Answered

I am going to implement an extensions. here is the code

"go" is high-lighted in red and shows ""

<depends>com.intellij.modules.platform</depends>
<depends>org.jetbrains.plugins.go</depends>

<extensions defaultExtensionNs="com.intellij">
<!-- Add your extensions here -->
<completion.contributor language="go"
implementationClass="xxxxx"/>
</extensions>
20 comments
Comment actions Permalink

Hi,

Please, provide an output of build.gradle file (intellij { ... } section).

0
Comment actions Permalink

 

here is 

by the way I am using build.gradle.kts.

intellij {
version = "2021.1"
type = "GO"
setPlugins("org.jetbrains.plugins.go:211.6693.14")
}

 

0
Comment actions Permalink

I didn't see any suspicious here. Could you please share a link to your plugin on Github/Gitlab/etc.?

0
Comment actions Permalink

Please, try reimporting your Gradle project.

0
Comment actions Permalink

still the same issue!

by the way is there a dedicated slack channel?

0
Comment actions Permalink

I've moved your question to the corresponding thread. Stay tuned.

0
Comment actions Permalink

Can you tell me which channel you moved to? Then I can follow it in the slack.
Thank you very much

0
Comment actions Permalink

I moved your thread on our community forum from GoLand to IntelliJ IDEA Open API and Plugin Development.

0
Comment actions Permalink

Please follow official guide https://plugins.jetbrains.com/docs/intellij/goland.html

Don't mix "GO" in intellij block with additional requiring Go plugin

0
Comment actions Permalink

Don’t understand your point. As you can see in my source code, the action work well. Can you point out what should I do to fix this issue? Thank you very much

0
Comment actions Permalink

You define target platform=GO=Goland and in addition you set additional Go Plugin (standalone) in your Gradle build.

0
Comment actions Permalink

You mean remove the plug-in will fix this issue?

0
Comment actions Permalink

It is definitely wrong and it might fix the issue. The underlying problem is the Language-class implementing Go is not resolved properly now in your project.

0
Comment actions Permalink

By the way, I checked source code of go struct tag autocomplete and found that if the built-in go struct tag supply a method to add customize tag definition then I don’t need to create a new extension. Not sure it’s feasible or not. I would like to request a feature. It’s would be great the platform to support this! Thank you very much

1
Comment actions Permalink

Sure, thank you very much.

0
Comment actions Permalink

Seems a lot of guys run into the same issue, I will check the document again try to resolve this problem,As right now I am not around my computer. Meanwhile I will raise a feature request, as for my case it’s better to use the built-in functionality.

0

Please sign in to leave a comment.