PHPstorm Settings Issue

There are a couple of things that recently started happening in PHPstorm that I'm uncertain what I did that might have caused it.

  1. For example when I type in an element/tag in PHP or HTML and press enter the curser is moving to the end of the line instead of moving the closing tag to the next line. I'm sure I've messed up a setting somewhere can't seem to figure out what I messed up along the way.
  2. The other issue I'm having is when adding my classes to an element in HTML it's no longer showing the pop-up with options to select. This does seem to work correctly when using Laravel but in this case I started a blank project and manually add the HTML files. I'm attempting to use Tailwind and have added the tailwind CDN link as well as running the NPM command to install, but still not seeing the auto-complete box pop-up.
  3. I'm also having issues with file formatting. For example when tags get unaligned and I try to reformat the page, nothing happens.

I'd appreciate others thoughts on how to resolved the issues. 

Thank you!


Would it be possible to illustrate the first and third concerns with a screencast or code examples where it is reproducible?


@Vasiliy Yur

Thanks for the reply. I think I was able to sort out issues 2 & 3. I've included a link showing issue #1


Thanks for sharing the recording.
Unfortunately, I was not able to reproduce the issue on my side.

- Does it work the same if you just type the tag manually without a live template?
- What if you type anything inside of the tag, will the enter work fine then?
- A little bit generic question but nonetheless, do you have any custom plugins enabled?

  • When typing it out manually <div> auto complete adds the closing tag and pressing [ENTER] performs as I expect by moving the closing tag to the next line.
  • If I type <div>[TAB] autocomplete adds closing tag and places curser between them. Typing in text and pressing [ENTER] highlights the < > on each end, then hitting [ENTER] one more time moves the curser to the next line leaving everything I just typed on the line above.
  • I don't believe I have any custom plugins installed. All the ones I have came from the marketplace. 

One thing I noticed when setting up another computer is that it works just like I expect it to which tells me I've messed up a setting somewhere along the way I'm just not sure which one.



Please check if you have the "Add edit point at the end of template" option enabled in "Editor | Emmet | HTML". If it is, disable it please, and try to reproduce the scenario again.


Vasiliy Yur, I was able to check this setting however it was already unchecked. I've since decided to to just remove the software and install it again which seems to have resolved the issue. Thanks again for your assistance!


Please sign in to leave a comment.