Testing with internal server -> wrong path !

When testing my index.php from inside phpstorm (using Build-in Preview or Chrome) no stylesheet or scripts etc are loaded unless I add '/www/public_html' to all href/src/... 

Brower url:   http://localhost:63228/www/public_html/index.php?_ijt=7c5k367o8a411nl30ncr40c9r6

Not working  =>   <link rel="stylesheet" href="/css/main.css?rnd=1623715157">

Working  =>   <link rel="stylesheet" href="'/www/public_html/css/main.css?rnd=1623715157">

Is there a way to solves this problem in the settings ? 

 

 

 

 

1 comment
Comment actions Permalink

In fact, you should use the project name in path (I guess, this is "/www/" in your case) with the built-in web-server, this is a known limitation: 

https://youtrack.jetbrains.com/issue/WEB-11949 

0

Please sign in to leave a comment.