Plugin 'JXYZ' requires plugin 'com.intellij.microservices.uast' to be installed


We have updated to 2021.1.2 an after restart the IDE, the "Spring" Plugins didn't work.

The "Spring" plugins have the same problem, as other plugins:

Plugin error
Plugin 'Java EE: Message Service (JMS)' requires plugin 'com.intellij.microservices.uast' to be installed
Plugin 'Java EE: WebSockets' requires plugin 'com.intellij.microservices.uast' to be installed
Plugin 'Quarkus' requires plugin 'com.intellij.microservices.uast' to be installed
Plugin 'Java EE: Web Services (JAX-WS)' requires plugin 'com.intellij.microservices.uast' to be installed
Plugin 'Java EE: RESTful Web Services (JAX-RS)' requires plugin 'com.intellij.microservices.uast' to be installed

But where we can install / update the missing system plugin "com.intellij.microservices.uast"  ??



Hi Florian,

What is your OS? How did you install / update your IDE?

Please collect the logs (Help | Collect Logs and Diagnostics Data), upload them to and provide the upload id so that we can check.


We use LINUX as OS.
I updated with the normal UI menu "Check for Update" .....

To solve the problem I download the full tar packege from your website and copy these two plugin files:


These are still in the path, I override them.
After that, the "Plugin Errors" are solved.....   but the indexing of the project fails with many errors.....   

I send you the logs via upload service:  Upload id: 2021_06_17_3dtiEBkBJU4e2tht (file:

Maybe this will help you to fix the "Update failure".....

For me.... I decide to remove the installation folder completely.
After that i extract the new downloaded IntelliJ-Package....

Now, I have running version, without failure,  at the moment :-)    !!

So my problem is solved.....    but your "Update process" is terrible...  sorry.


Thanks for the info Florian. Good to know you managed to resolve the issue.

I created a bug report for this on our issue tracker too: IDEA-271867.

Responsible developers will analyze the logs you provided and hopefully come up with a permanent solution, or at least an explanation of why it happened in the first place and how to avoid it.

See this article if you are not familiar with YouTrack.


Were there any errors or warnings during the update? Updater log files (`idea_updater*.log`) are suspiciously missing from the uploaded archive.


There are no failures in the Frontend during the update.  But maybe on console... I don't look at it at this time...

After the update restart of the IDE, there are the warnings for the bugy "Spring" plugins...
We use a "SAP Commerce / Hybris" Plugin.. after the update, this plugin was no longer running too and we have to change to antoher one ... so this was the only "failure / warning"   during or after the update.

Maybe this info will help....   if not, you can close the ticket. 
As i wrote, we install IntelliJ new ... now it's running without failures. The settings are still there, so it's ok for me :-)


I see, thanks, just trying to understand what might went wrong and when.

Just to be sure: you started the IDE, invoked _Help | Check for Updates_, clicked through the UI and agreed to restart the IDE, waited for the patch to be applied (and there were no errors or warnings at this stage, just a couple progress bars), then the IDE restarted, and after that plugins blew up. Correct?



yes after the update we restarted the IDE..  and after that the plugins blew up.

That's correct. 

It seems, that not all plugins have the needed (same) new version after update the IDE.


I see, thanks. Something went wrong during the update, but without updater logs, it is impossible to figure out the reason :(


Please sign in to leave a comment.