Cannot upgrade kotlin plugin

I get an "update kotlin plugin" popup from time to time, like this:

A new version 211-1.5.10-release-891-IJ7142.45 of the Kotlin plugin is available.

but whenever I try to install it I get a message:

Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.0-release-759-IJ6693.72).

So how to update it?

IntelliJ IDEA 2021.1.1 (Ultimate Edition)
Build #IU-211.7142.45, built on April 30, 2021
Subscription is active until July 17, 2021.
Runtime version: 11.0.10+9-b1341.41 amd64
VM: Dynamic Code Evolution 64-Bit Server VM by JetBrains s.r.o.
Linux 5.8.0-53-generic
GC: ParNew, ConcurrentMarkSweep
Memory: 9981M
Cores: 8
Non-Bundled Plugins: Base64 for IDEA and Storm (1.1b), Batch Scripts Support (1.0.12), CMD Support (1.0.5), Dilbert (, IdeaVIM (0.67), Statistic (4.1.7), com.alayouni.ansiHighlight (1.2.4), com.github.leomillon.uuidgenerator (4.4.0), com.intellij.apacheConfig (211.6693.108), com.intellij.ideolog (, com.jetbrains.plugins.ini4idea (211.6693.44), com.intellij.plugins.watcher (211.6693.44), com.khmelyuk.multirun (1.11.2), com.sburlyaev.terminal.plugin (0.4.4), (100.001), detekt (1.17.1), (4.3.1-p0), nl.jworks.intellij.bootstrap3 (4.1.1), org.github.plugin.redis-simple (1.1.4), org.intellij.plugins.hcl (0.7.10), com.crunch42.openapi (1.15), org.sylfra.idea.plugins.linessorter (1.0.1), (1.4.4), send2terminal (1.4.1), GrepConsole (, SpotProfiler (2.0), com.euphoricity.gitignore (0.3), com.github.syuchan1005.ImageComment (1.0.2), com.intellij.bigdecimal-folding (, com.linsage (1.0.6), de.u-mass.idea.copyConstructor (1.2), marcglasberg.HibernateInspectionsPlugin (1.1), org.sonarlint.idea (, com.deadlock.scsyntax (211.6693.111), com.ifengxue.plugin.jpa-support (2.0.7-RC3), org.jetbrains.kotlin (211-1.5.0-release-759-IJ6693.72), com.bruce.intellijplugin.generatesetter (2.7), com.suusan2go.kotlin-fill-class (1.0.7), org.mapstruct.intellij (1.2.4), com.intellij.plugins.html.instantEditing (211.6693.111), org.jetbrains.plugins.ruby (211.7142.36), PlantUML integration (5.3.0), Pythonid (211.7142.45), net.ashald.envfile (3.2.1), ru.adelf.idea.dotenv (2021.1), nl.rubensten.texifyidea (0.7.6)
Kotlin: 211-1.5.0-release-759-IJ6693.72
Current Desktop: ubuntu:GNOME

Related log file:

2021-06-01 09:20:56,782 [327379998] INFO - er.VisualOperatorActionHandler - Execute visual command Command(rawCount=0, action=com.maddyhome.idea.vim.action.change.change.ChangeVisualAction@4d5272dc, type=CHANGE, flags=[FLAG_EXIT_VISUAL, FLAG_MULTIKEY_UNDO])
2021-06-01 09:21:02,331 [327385547] INFO - rketplacePluginDownloadService - Unable to download plugin via blockmap$HttpStatusException: Request failed with status code 404. Status=404, Url=
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService$downloadPluginViaBlockMap$newBlockMap$1.process(MarketplacePluginDownloadService.kt:69)
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService$downloadPluginViaBlockMap$newBlockMap$1.process(MarketplacePluginDownloadService.kt:23)
at com.intellij.ide.plugins.marketplace.MarketplacePluginDownloadService.downloadPluginViaBlockMap(MarketplacePluginDownloadService.kt:68)
at com.intellij.ide.plugins.marketplace.MarketplaceRequests.downloadPluginViaBlockMap(MarketplaceRequests.kt:384)
at com.intellij.openapi.updateSettings.impl.PluginDownloader.downloadPlugin(
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstallAndLoadDescriptor(
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstallAndLoadDescriptor(
at com.intellij.openapi.updateSettings.impl.PluginDownloader.prepareToInstall(
at org.jetbrains.kotlin.idea.KotlinPluginUpdater$installPluginUpdate$
at com.intellij.openapi.progress.impl.CoreProgressManager$
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcessWithProgressAsync$5(
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$3(
at com.intellij.openapi.progress.impl.CoreProgressManager.lambda$runProcess$2(
at com.intellij.openapi.progress.impl.CoreProgressManager.registerIndicatorAndRun(
at com.intellij.openapi.progress.impl.CoreProgressManager.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.ProgressManagerImpl.executeProcessUnderProgress(
at com.intellij.openapi.progress.impl.CoreProgressManager.runProcess(
at com.intellij.openapi.progress.impl.ProgressRunner.lambda$submit$4(
at java.base/java.util.concurrent.CompletableFuture$
at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.base/java.util.concurrent.ThreadPoolExecutor$
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$1$
at java.base/ Method)
at java.base/java.util.concurrent.Executors$PrivilegedThreadFactory$
at java.base/
2021-06-01 09:21:06,631 [327389847] INFO - Settings.impl.PluginDownloader - Plugin org.jetbrains.kotlin: current version (max) 1.3.72-release-IJ2020.1-5
2021-06-01 09:21:06,631 [327389847] INFO - Settings.impl.PluginDownloader - PluginDownloader error: Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.0-release-759-IJ6693.72).

I still get that message


11:09 Kotlin: A new version 211-1.5.10-release-909-IJ7142.45 of the Kotlin plugin is available. Install

Error message

Plugin "Kotlin" was not installed: Downloaded version (1.3.72-release-IJ2020.1-5) is older than the currently installed version (211-1.5.10-release-891-IJ7142.45).

Note that it says that "A new version 211-1.5.10-release-909-IJ7142.45 is available and then Downloaded version (1.3.72-release-IJ2020.1-5) ...


However in the Settings → Plugins the version information says

211-1.5.10-release-891-IJ7142.45 → 211-1.5.10-release-909-IJ7142.45

and after clicking "update" it says the version is



Same problem on my machines. Seems that I have to work with Kotlin 1.5.10 for the time being and coming, because all newer plugins are older and will not be installed.

Really confusing.


And again the Kotlin plugin 1.5.31 cannot be installed because my old is newer (!?!?!) than anything that will come in the future. Will I ever get a new Kotlin version again? I doubt.


Same here. However when I closed all projects and disabled Kotlin plugin in the "Welcome" window, then it updated to 1.5.31. Then I re-enabled it and it stays on 1.5.31.


Thank you, Lutosław, very much. This worked for me. Tried on one of my machines and it was successful.

Closed all projects. Disabled the Kotlin plugin on the Welcome-page. Then updated the plugin and enabled it again (with obligatory restarts after each change).

Nice ;-)


I'm stuck again in this problem. After upgrade of IntelliJ to 2021.3, the bundled Kotlin plugin 1.5.30 is back and I'm not able to update it to 1.6.0 . Seem's it'll take a serious time span to solve this ...


+1 to this thread.  This has been a concern for me since beta & RC versions of Kotlin 1.6, and is still a problem.  I'll use IntelliJ as the editor, and cross-check any complaints by building on the command line (Maven or Gradle).  It slows down my coding flow.


I'm also facing this issue, stuck on Kotlin 1.5.10, check for updates doesn't prompt for any changes. And I don't see any possible "update" button on the Kotlin plugin itself. 


I uninstall IDEA, removed all files from my mac, all caches, Install lastest 2021.3 version. AND still have kotlin plugin 1.5.10.
Some time a get suggestion to update plugin to 1.6.0, but after that I receive Error.
Can't update plugin at least for 1 year

P.S. Fixed for me 👍🏻(25 Dec 2021)


This hit me hard today...

I tried workaround suggested by Lutosław, but with no luck.

What information we need to provide to solve this issue? 


Interestingly, the last stable versions of the Kotlin plugin seem to be incompatible with IntelliJ IDEA 2021.3. It seems to me like the root cause for this problem.

Update: There is now an RC version compatible with IDEA 2021.3:


This is fixed for me -- should have posted earlier -- in 2021.3.1 Preview version of IntelliJ.


It's also fixed for IDEA version 2021.3 by now as the Kotlin 1.6.10 plugin has been released with IDEA version 2021.3.x compatibility.


Please sign in to leave a comment.