Editor tweaks

Completed

2 strange issues happened recently on my Goland Editor settings and I can't seem to find any documentation or settings for these.  I didn't change anything so I can only presume that an upgrade set these to something else:

1. Only one tab stays open. If I open another file, it doesn't line up next to the other.  Very annoying when trying to work across several files at the same time.  

2. A huge margin in the editor to the left of the code.  I cannot find anywhere to reduce this margin (preferably to nothing).  Empty space for nothing, and I find no settings for this.

Thanks,

 

Jayson

0
10 comments
Official comment

Hello Jayson,

Only one tab stays open. If I open another file, it doesn't line up next to the other.  Very annoying when trying to work across several files at the same time.  

Could you please try to disable Preferences / Settings | Editor | General | Editor Tabs | Open declaration source in the same tab option? What are your Preferences / Settings | Editor | General | Editor Tabs | Tab limit value?

A huge margin in the editor to the left of the code.  I cannot find anywhere to reduce this margin (preferably to nothing).  Empty space for nothing, and I find no settings for this.

You can configure a left margin by right-clicking on it and disable options. I assume you're speaking about gutter icons and space for them. You can disable it in Preferences / Settings | Editor | General | Gutter Icons | Show gutter icons.

I hope it helps.

Thanks for the quick response Daniil.

1. I upgraded and now the tabs are visible and don't disappear.  My tab limit was and is still set at 10.

2. If I right click in the big left margin, I did "show gutter icons" both on and off (top check box) and I still have a huge margin either way.  Same issue.

I'm now at version 2021.1.2

0

I upgraded and now the tabs are visible and don't disappear.  My tab limit was and is still set at 10.

The current behavior is unexpected, and we plan to fix it. Please see and follow IDEA-255328.

If I right click in the big left margin, I did "show gutter icons" both on and off (top check box) and I still have a huge margin either way.  Same issue.

Could you please provide a screenshot of a huge margin?

0

Please, try the following steps:

  • Invoke Help | Find Action | Registry (or Shift+Shift and type Registry).
  • Find editor.distraction.free.mode and disable it.

Does it help?

0

That did it!  I have no idea how this was ever set.  Fantastic.

0

I think you enabled Distraction Free Mode (View | Appearance), and it's a known issue, please see and follow IDEA-148002.

In the 2021.2 version (EAP is available), you will be able to configure a left margin manually in the settings.

0

OK - yes, I don't see the "Advanced Settings" or the "String Manipulation" items yet in my version.  I will look for this when 2021.2 is released.

With Distraction Free Mode, when enabled, only the editor was visible and took up my whole screen. The strange part of this is that I had not enabled Distraction Free Mode and the rest of Goland as well as my Windows status bar were still visible.  It's as if a partial Distraction Free Mode...  I'm guessing that's the crux of the issue.

0

It's as if a partial Distraction Free Mode...  I'm guessing that's the crux of the issue.

Yes, sometimes it happens without Distraction Free Mode. Please follow IDEA-148002 to stay tuned.

0

Will do.

Thanks!

0

Please sign in to leave a comment.