Xdebug: configured, confirmed, when listening page is not loading

Hi!

I'm on PHPStorm 2017.3 on Windows 10, with vagrant testing server on the same machine. Recently I've updated vagrant box to have newest Postgres 13 and PHP7 (I'm recoding old client's website to newer server specs). Until then the PHPStorm/Vagrant/Xdebug configuration was working as a charm. Since the update I'm having such issue:

Xdebug is installed, PHPStorm validation in Settings windows is showing that all is OK, website is running, reloading and everything is fine. But when I start listening for PHP debug connections (I have the chrome Xdebug extension installed), and reload a page - the page stays blank and loading (even though there are no breakpoins in the script).

The Xdebug log is not even created. I tried to switch off Windows Defender Firewall, but it didn't help. Ubuntu firewall is inactive.

What is wrong? Please help! It's another (4th) weekend wasted searching for solution to this issue. :((((((((((

 

My Xdebug config:

[Xdebug]
zend_extension=xdebug.so
xdebug.remote_enable=1
xdebug.remote_autostart=0
xdebug.remote_host=192.168.1.254
xdebug.remote_port=9000
xdebug.idekey=XDEBUG_ECLIPSE
html_errors=0
xdebug.remote_log=/tmp/xdebug-remote

phpinfo() fragments:

PHP Version 7.4.9

with Xdebug v2.9.6, Copyright (c) 2002-2020, by Derick Rethans

HTTP_COOKIE: XDEBUG_SESSION=XDEBUG_ECLIPSE

xdebug

xdebug support enabled
Version 2.9.6
 
Debugger enabled
IDE Key XDEBUG_ECLIPSE
Directive
Local Value
Master Value
xdebug.auto_trace
Off
Off
xdebug.cli_color
0
0
xdebug.collect_assignments
Off
Off
xdebug.collect_includes
On
On
xdebug.collect_params
0
0
xdebug.collect_return
Off
Off
xdebug.collect_vars
Off
Off
xdebug.coverage_enable
On
On
xdebug.default_enable
On
On
xdebug.dump.COOKIE
no value
no value
xdebug.dump.ENV
no value
no value
xdebug.dump.FILES
no value
no value
xdebug.dump.GET
no value
no value
xdebug.dump.POST
no value
no value
xdebug.dump.REQUEST
no value
no value
xdebug.dump.SERVER
no value
no value
xdebug.dump.SESSION
no value
no value
xdebug.dump_globals
On
On
xdebug.dump_once
On
On
xdebug.dump_undefined
Off
Off
xdebug.file_link_format
no value
no value
xdebug.filename_format
no value
no value
xdebug.force_display_errors
Off
Off
xdebug.force_error_reporting
0
0
xdebug.gc_stats_enable
Off
Off
xdebug.gc_stats_output_dir
/tmp
/tmp
xdebug.gc_stats_output_name
gcstats.%p
gcstats.%p
xdebug.halt_level
0
0
xdebug.idekey
XDEBUG_ECLIPSE
XDEBUG_ECLIPSE
xdebug.max_nesting_level
256
256
xdebug.max_stack_frames
-1
-1
xdebug.overload_var_dump
2
2
xdebug.profiler_append
Off
Off
xdebug.profiler_enable
Off
Off
xdebug.profiler_enable_trigger
Off
Off
xdebug.profiler_enable_trigger_value
no value
no value
xdebug.profiler_output_dir
/tmp
/tmp
xdebug.profiler_output_name
cachegrind.out.%p
cachegrind.out.%p
xdebug.remote_addr_header
no value
no value
xdebug.remote_autostart
Off
Off
xdebug.remote_connect_back
Off
Off
xdebug.remote_cookie_expire_time
3600
3600
xdebug.remote_enable
On
On
xdebug.remote_host
192.168.1.254
192.168.1.254
xdebug.remote_log
/tmp/xdebug-remote
/tmp/xdebug-remote
xdebug.remote_log_level
7
7
xdebug.remote_mode
req
req
xdebug.remote_port
9000
9000
xdebug.remote_timeout
200
200
xdebug.scream
Off
Off
xdebug.show_error_trace
Off
Off
xdebug.show_exception_trace
Off
Off
xdebug.show_local_vars
Off
Off
xdebug.show_mem_delta
Off
Off
xdebug.trace_enable_trigger
Off
Off
xdebug.trace_enable_trigger_value
no value
no value
xdebug.trace_format
0
0
xdebug.trace_options
0
0
xdebug.trace_output_dir
/tmp
/tmp
xdebug.trace_output_name
trace.%c
trace.%c
xdebug.var_display_max_children
128
128
xdebug.var_display_max_data
512
512
xdebug.var_display_max_depth
3
3
0
4 comments

Hi there,

PHPStorm 2017.3

with Xdebug v2.9.6

Xdebug 2.7+ requires PhpStorm 2018.3 or newer.

You have to upgrade your PhpStorm. P.S. And you better upgrade Xdebug to the latest 2.9.8 in 2.9 branch... or better to Xdebug v3 (in such case please also see Xdebug: Upgrading from Xdebug 2 to 3 )

Cannot comment on the "page remains loading" / "no log gets created" parts.

Although: on certains systems like modern Ubuntu the /tmp path is "virtualized" per app  ("private tmp").. so "/tmp/xdebug.log" in reality might be "/tmp/some-sort-of-id/xdebug.log" instead -- see https://xdebug.org/docs/step_debug#log for details (at the end)

1

This error usually indicates that the Amazon WorkSpaces client can authenticate over port 443, but can’t establish a streaming connection over port 4172. This can happen when network prerequisites aren’t met. Issues on the client side often cause the network check in the bottom-right corner of the client to fail.

-2

OK, Andriy Bazanov,

thanks for your response. I've tried many options for last few weeks. But with no success... I even got back to my previous configuration, with older Ubuntu Trusty, with PHP5, with Xdebug 2. Validation tool in PHP/Debug settings shows that everything is okay. And I still cannot make the PhpStorm and Xdebug cooperate again... 

I've turned back to my previous setup of PhpStorm and server, I've checked the Chrome Xdebug plugin...

And now when I set the Chrome Plugin to debug (the green bug icon is on), and I turn on "Start listening for PHP debug connections", and reload the website (local domain configured on ubuntu on VM), the browser starts loading... and it's in loading state... and you amy wait as long as you wish, with no result... But as soon as you turn off the "Start listening for PHP debug connections" in PhpStorm, the website loads immediately. So it looks like PhpStorm is blocking the connection between browsed and server. Of course when I switch off the listening mode I have no debugging data...

What's happened? I've had the environment working for few years. I just need to update the website a bit as the source data and sever stepped on new software and format, and I need the debugging to destruct the huge amounts of data I receive. I'ts a task for few days, and I've just spent weeks on the xdebug issue... Please help! :(

0

1. IDE version? It looks a bit old to me...

2. Enable Xdebug log, try to debug and show what it has to say.

P.S. One screenshot shows Xdebug v2.5.x; another shows v2.2.x ...

0

Please sign in to leave a comment.