Webstorm Debug Javascript in browser keeps defaulting to Chrome even though I set Firefox to the default

As you can see in the screenshot,

1. Firefox is checked,

2. has the proper file path

3. Default Browser is set to "First listed" with Firefox as the path. I also tried system default with Firefox as my default browser.

However, when I press the debug button, a Chrome window still pops up to do the debugging. How do I set Firefox to open up when I hit debug.

2 comments
Comment actions Permalink

Hi there,

JavaScript debug is for Chrome-based browsers only.

To debug JavaScript using Firefox you need to use Firefox Remote type of Run/Debug Configuration (need to manually create and use it) and enable Remote Debugging in Firefox in advance. https://www.jetbrains.com/help/phpstorm/debugging-javascript-in-firefox.html has all the info.

 

On related note: https://youtrack.jetbrains.com/issue/WEB-14987

1
Comment actions Permalink

In addition to what's written above: unfortunately, there's nothing we can offer for debugging in Firefox now :(
We used to support Firefox Remote Debugging (but without source maps) through the FireFox Remote run configuration, but our solution doesn't work in the latest Firefox versions due to changes in the protocol, and there doesn't seem to be an easy way to fix it. We've made some progress recently, but there are still some blocking issues.

Related tickets: https://youtrack.jetbrains.com/issue/WEB-45986, https://youtrack.jetbrains.com/issue/WEB-48076, https://youtrack.jetbrains.com/issue/WEB-2337

0

Please sign in to leave a comment.