MySQL connection stopped working

Answered

After updating to version 2021.1.3, my connections to MySQL completely stopped working, everything works fine through MySQL Workbench. Tell me what to do in this situation?

[08S01]
Communications link failure

The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.
javax.net.ssl.SSLHandshakeException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate).

4 comments
Comment actions Permalink

That's a known problem, please try workarounds listed here: https://youtrack.jetbrains.com/issue/DBE-13313

1
Comment actions Permalink

You can temoprary disable ssl for connection. That's why Workbench works (Use SSL option is no by default)

6
Comment actions Permalink

Can somebody explain why disabling ssl for connection works? This solved my issue but it would be nice to know why.

0
Comment actions Permalink

@Dominik Vogt

As per https://youtrack.jetbrains.com/issue/DBE-13313 the issue was fixed a year ago.

As I understand this comment describes the issue: https://youtrack.jetbrains.com/issue/DBE-13313/Cant-connect-to-remote-MySQL-since-last-version-of-IntelliJ#focus=Comments-27-4939120.0-0

We are about to release bugfix, that will suggest you quickfix to enable unsecure protocols. The error relates to older mysql versions that has only TLSv1.0, TLSv1.1 and those that also have bug in TLSv1.2 implementation

Anyway, just go through the comments in that ticket and you will have a proper picture.

2

Please sign in to leave a comment.