How to run Rubocop with bundle exec?

Previously I was able to run Rubocop in the IDE with no issues. I'm not sure what changed, but now when I run it, I get this error: 

Error:Rubocop returned exit code: 2
stderr:
warning: parser/current is loading parser/ruby24, which recognizes
warning: 2.4.10-compliant syntax, but you are running 2.4.1.
warning: please see https://github.com/whitequark/parser#compatibility-with-ruby-mri.
Could not find 'activesupport' (>= 4.2.0) among 288 total gem(s)
Checked in 'GEM_PATH=/Users/Ryan/.rbenv/versions/2.4.1/gemsets/OneSignal:/Users/Ryan/.rbenv/versions/2.4.1/gemsets/global:/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/gems/2.4.0', execute `gem env` for more information
/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/dependency.rb:308:in `to_specs'
/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/specification.rb:1442:in `block in activate_dependencies'
/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/specification.rb:1431:in `each'
/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/specification.rb:1431:in `activate_dependencies'
/Users/Ryan/.rbenv/versions/2.4.1/lib/ruby/2.4.0/rubygems/specification.rb:1413:in `activate'
/Users/Ryan/.rbenv/version ...

I get the same error when I run it in the terminal, but if I run it with "bundle exec rubocop" it runs fine. How can I get Rubymine itself to run Rubocop in the context of bundle exec?

1 comment
Comment actions Permalink

Since you've also left a comment in the similar issue on the tracker (https://youtrack.jetbrains.com/issue/RUBY-26915) it'd be better to continue the discussion there. 

0

Please sign in to leave a comment.