Is a VCS config necessary for gutter colors (changed lines etc)?

Answered

I've never made use of VCS in intJ -- I use git but it seemed simpler to me when I first started using the IDE to just keep doing what I was doing manually and ignore the occasional popup.  I'm still fine like that.

Gutter colors are something I've paid occasional attention to, but not enough that them being there or not is something I think about, until right now, when suddenly I want to be able to find recently changed lines.

Which is when I noticed there are no gutter colors at all.  I read in a few bug reports this might be just because of a particular color scheme, but when I switch to standard Darcula nothing changes.

Then looking for the gutter color configuration I noticed these are actually tied to the VCS interface.  Do I need to configure that somehow in order for this to work?  And tangentially, can I do it in a "read-only" way? I do little scripting things with git and would just prefer that nothing complicate that (currently, `.git` is there but read-only for the intJ process). 

3 comments
Comment actions Permalink

Hello!

Without enabled VCS integration there will be no indication of modified lines in the gutter.
You can enable it by going to Preferences | Version Control and adding your project to registered roots.
Also you can enable staging area in IDE, please go to Preferences | Version Control | Git and check "Enable staging area"

As for "read-only mode" please feel free to vote and comment:
https://youtrack.jetbrains.com/issue/IDEA-194592

1
Comment actions Permalink

Hmmph.  I noticed after this that VCS gutter colors do work in Clion, with a read-only git.  Then suddenly today I fire up intJ and behold, it is also working there.

 

I have no idea what made the difference.

0
Comment actions Permalink

 > I noticed after this that VCS gutter colors do work in Clion, with a read-only git.  Then suddenly today I fire up intJ and behold, it is also working there.

Could you please elaborate a bit more on this? What do you mean by "with a read-only git"? Have you enabled "Git staging area"?

0

Please sign in to leave a comment.