forcing Intellij to use Headless mode?

Answered

Hello I am writing an idea plugin that also overwrites the Appstarter extension in order to run as command line app. 

I want it to run in Headless mode but whatever iI do it keeps opening the gui. 

isHeadless(){
     return true;
}

and in the idea VM options file  -Djava.awt.headless=true is set.
What else do I need to do in order to force headless mode?

2 comments
Comment actions Permalink

Additional note: 

meanwhile I tested further and discovered that the gui only starts in a Windows environment. When run in Linux the headless mode executes as expected. 

Is this already known or a new bug? 

0

Please sign in to leave a comment.