Can't see the Docker option under python Interpreter to connect remotely

I am using Mac OS and Community Edition of Pycharm. I have installed Docker plugin and while setting up docker as remote interpreter I am not able to see the option of Docker under Add Interpreter. I am not sure what is the problem.
I have also attached the screenshot for the reference where on the left hand side panel I am supposed to see the Docker option which I can't see.

Is docker is not supported for Community edition of Pycharm? Or is there any other problem? 

I would appreciate if any one could help me with this.



Docker and Docker Compose support is part of PyCharm Professional as can be found in


We're having the same problem here. Would love a response to this issue. We have the docker plugin, we can connect to the docker service, see containers, but docker doesn't show up as an option for the python interpreters.



Are you using PyCharm Professional? Could you please provide your Logs from **Help | Collect Logs and Diagnostic Data**? 

You can use uploading service at , and provide upload ID in your reply.


Hello, I have the same problem with Pycharm Community edition. Is adding docker as Python interpreter not possible using the Docker Plugin of Pycharm Community? Many Thanks in advance!

Please note that Docker support only exists in PyCharm Professional.

So please add PyCharm Professional as a paid plugin to all other ideas, i have a project that is running in docker and written in go and go is running a python script, Goland is not detecting my docker python env and PyCharm is not good with go


Yweing0720 As of now, the Python community edition plugin is available  to IDEs such as GoLand, Rider, DataGrip, and RustRover -  - Which is why you can't see you docker env by default

Other IDEs do have the PyCharm Professional features.


I have the same problem on the Professional edition. I have an existing interpreter that doesn't work (this was the reason why I found I couldn't add a new docker [compose] interpreter).

It happened after switching to 241.9959.30



downgrading fixed the problem



Please sign in to leave a comment.