Rebuild doesn't work for changed files (CLion)

Completed

Hello,

I have to always press "clean" before the "Run" so that changes appear in my program. My project contains mostly " .h or .hpp files" without .cpp.

-First run is fine. Building, Linking.. and it takes some time

-Then I go to the .h or .hpp files and making my changes

-Clicking "Run"

-App is opened but without any change.

-Trying to click "Build->Recompile MyFile1.h" (no results, still no changes after run)

-Trying to click "Build->My Project" (no results, still no changes after run)

-Trying to click "Clean" (TADA! I now have the changes after run)

I don't seem noticed this issue when I do .cpp changes. The issue seems only with .h/hpp files.

Please help. I'm tired of waiting for 3-5 minutes of compilation after each "Clean". Thanks!

P.S. and "Yes" I have "Build" in the "Before Lunch" settings. When I use Xcode I don't see this issue.

----

Model Name: MacBook Pro

 

  Chip: Apple M1

  Total Number of Cores: 8 (4 performance and 4 efficiency)

  Memory: 16 GB

System Version: macOS 11.4 (20F71)

  Kernel Version: Darwin 20.5.0

2 comments
Comment actions Permalink

Nope. sorry I just tried with .cpp and have the same issue.

0
Comment actions Permalink

Hello!

Please install CLion 2021.2 RC (https://www.jetbrains.com/clion/nextversion/, choose ".dmg (macOS Apple Silicon)") and check whether the issue happens in it. If it does, please do Help | Collect Logs and Diagnostic Data and send the resulted archive to clion-support at jetbrains.com. Note that logs might contain private user's information (like file paths and names).

0

Please sign in to leave a comment.