Gradle plugin build fails: Received status code 403 from server: Forbidden

Answered

Hi,

I am getting the following error lately on my build-pipeline (https://github.com/SeeSharpSoft/intellij-csv-validator/actions) stating:

---

> Could not resolve org.jetbrains.intellij.deps.jflex:jflex:1.7.0-1.

---

 

Locally I am getting similar errors:

 

---

Execution failed for task ':instrumentCode'.
> Could not resolve all files for configuration ':detachedConfiguration3'.
> Could not download asm-all-9.1.jar (org.jetbrains.intellij.deps:asm-all:9.1)
> Could not get resource 'https://jetbrains.bintray.com/intellij-third-party-dependencies/org/jetbrains/intellij/deps/asm-all/9.1/asm-all-9.1.jar'.
> Could not GET 'https://jetbrains.bintray.com/intellij-third-party-dependencies/org/jetbrains/intellij/deps/asm-all/9.1/asm-all-9.1.jar'. Received status code 403 from server: Forbidden
> Could not download jdom-2.0.6.jar (org.jetbrains.intellij.deps:jdom:2.0.6)
> Could not get resource 'https://jetbrains.bintray.com/intellij-third-party-dependencies/org/jetbrains/intellij/deps/jdom/2.0.6/jdom-2.0.6.jar'.
> Could not GET 'https://jetbrains.bintray.com/intellij-third-party-dependencies/org/jetbrains/intellij/deps/jdom/2.0.6/jdom-2.0.6.jar'. Received status code 403 from server: Forbidden

---

I haven't changed anything in the gradle build script lately. What did just happen?

2 comments
Comment actions Permalink

Update Gradle IntelliJ Plugin to the latest version.

0
Comment actions Permalink

I already did it locally (maybe thats why I got different errors)...

...but now I tried updating everything, and the problem seems to be related to my outdated "gradle-grammar-kit-plugin"

classpath 'com.github.hurricup:gradle-grammar-kit-plugin:2018.1.1'

I upgraded it to

classpath 'com.github.hurricup:gradle-grammar-kit-plugin:2021.1.3'

and now it works.

Thank you for the quick response!

0

Please sign in to leave a comment.