Cannot run my first Cmake test program


Just installed CLion, started follow different tutorials(including those from official JetBrains site), but can't follow those really, since i failed on the very beginning.

1. After project created, it instantly gives two errors:


2. Second error can be "fixed" if i select C++ compiler manually, but by default, it can't be found(although files like g++.exe or c++.exe in folder exists):


3. And finally, all guiders on youtube have Run/Debug Configurations automatically, just after project is created, when i have none. debug/run/build icons all grey(disabled), and instead of configuration i just have "Add configuration". Here is Cmake profile settings window:


Something very wrong with my CLion or cmake. I'd say that MinGW is okay, because it was installed well recently, and i've used it yesterday with other IDE and it was okay.

P.S. i don't have Embarcadero RAD anymore, why it mentioned in error?



Please manually select "C:\MinGW\bin\g++.exe" in the "C++ Compiler" field, then do `Tools | CMake | Reset Cache and Reload Project`. Is the project loaded correctly after that? Od do you still get any errors in the CMake tool window?


Reset and Reload did'nt helped, first error remains.

P.S. tried to create Qt project, but found that it operated by CMake as well, not qMake, same error present.


1. Maybe you have Embarcadero mentions in PATH or somewhere else?

2. Please attach screenshots of current `File | Settings | Build, Execution, Deployment | Toolchains` and CMake tool window.


No Embarcadero stuff on PC left, all the rest files  of it deleted, as well as some invir.variables(but i did that when CLion was already installed and i had that errors). 

And just now i recalled that i had some practice with raw CMake long time ago, and yes, i found installed CMake from some 2018, and it's path specified as system variable. 

Deleted that all, now will try to reinstall CLion and will see if it 'll help.


It helped, i don't know what exactly, removing old CMake, or reinstalling CLion, or both. You guys should handle such a bug somehow, random new users like me spending 6-8 hours just for running "Hello World")).



I know it is years later, I thought this might help someone though.  If I remove entire .idea folder (removing contents is not enough) CLion kicks back into new configuration wizard mode.  This is the only way I know how to fix this issue.


Please sign in to leave a comment.