Disable built-in preview button

I'm using "PhpStorm 2021.2 Build #PS-212.4746.100, built on July 28, 2021" and seeing this button:

I'm also seeing it in projects which are by itself libraries (like in the above example) where it doesn't even make sense and it annoys me / creates noise in the interface (especially since it seems to appear after some seconds entering the editor, i.e. becomes visible/hidden, even further distracting me).

How can I disable this? I tried searching the settings but can't find anything:

thanks

3 comments
Comment actions Permalink

Hi there,

On your screenshot I see only one icon for the built-in entry. This tells me that you have disabled all other browser entries already. Try disabling the whole toolbar then:

"Settings/Preferences | Tools | Web Browsers --> Show browser popup in the editor"

https://stackoverflow.com/a/31761953/783119

2
Comment actions Permalink

Also, it is possible to disable built-in preview via the ide.web.preview.enabled Registry option (Help > Find Action > Registry)

0
Comment actions Permalink

Hi,

"Settings/Preferences | Tools | Web Browsers --> Show browser popup in the editor"

So, this is interesting, because this were the setting when I opened them:

It says "HTML" ; this setting wasn't deliberately, I assume it's a default etc.

Anyway, in my case I've clearly opened a `*.php` file but alas, this setting _also_ affects it.

So basically, yes, disabling "For HTML files" removes it the remaining preview to be shown for PHP files 🤷‍♀️

Also, it is possible to disable built-in preview via the ide.web.preview.enabled Registry option (Help > Find Action > Registry)

Ok, thanks, good to know! I'll go with the UI setting for now but keep this in mind.

All solves, thanks for your time :)

- Markus

0

Please sign in to leave a comment.