PyCharm does not load path to dynamic library


I want  to include the package tensorflow (installed), but loading the library

import tensorflow

returns the error

Could not load dynamic library ''; dlerror: cannot open shared object file: No such file or directory; LD_LIBRARY_PATH:

The file is in usr/lib/cuda-11.2/targets/x86_64-linux/lib (along with other versions), but even if I set the varuiable LD_LIBRARY_PATH to that directory in "Edit Configurations", it does not load (same error).


I would not blame it on PyCharm, except that it works perfectly fine if I run "import tensorflow" from python in the linux terminal, since the folder is in the system path.




Could you please run the following diagnostic script in PyCharm and in terminal and provide me with both outputs? You can

to the FTP and please let me know the filename. 


Also, please attach a screenshot of the Run Configuration, where the variable is set. 


I have a similar issue. Was it ever followed up or resolved? 


Please sign in to leave a comment.