Tools > Start SSH Session is missing

I am trying to start an SSH session in PyCharm professional through the "Tools" menu but the "Start SSH Session" option is missing.

I have also gone to Help > Find Action to search for this option but nothing comes up. 

I also went to Settings > Main Menu > Tools > + > Add Action, then search for it there but also nothing. 

I am able to configure SSH sessions at File > Settings > Tools > SSH Configurations. But then I can't do anything with it except for test the connection. 

Am I missing something here?

2 comments
Comment actions Permalink

Hi, could you please test if the issue is resolved by resetting IDE preferences to default by using **File | Manage IDE settings | Restore Default Settings...**. Your current settings will be backed up, so you can revert to them later (to do this, just import settings from the backed up folder).

If this doesn't help, could you please provide Logs from **Help | Collect Logs and Diagnostic Data**.

You can use uploading service at https://uploads.jetbrains.com/ , and provide upload ID in your reply.

1
Comment actions Permalink

Hi Andrey Resler

Restoring to default settings has fixed the issue. Thanks for your help!

0

Please sign in to leave a comment.