Bug - Slow operations are prohibited on EDT

This warning keeps popping up since I updated to build 212.4746.100. Is there something I can click to stop it appearing because the editor seems to work perfectly well

Thanks, Bill

9 comments
Comment actions Permalink

Could you please attach a screenshot of this?

0
Comment actions Permalink

photo on google https://photos.app.goo.gl/xpFDDWnBNPeixwqe8

if i clear the report, it pops up again later, several times a day. i've clicked the "report to jetbrains" so i assume they are working on it but it gets up my nose that i cant disable it because the editor seems to be working fine otherwise

Bill

0
Comment actions Permalink

Hm, this should be looked into in more details. Could you please submit this to our tracker at https://youtrack.jetbrains.com/newIssue or contact us via Help | Contact Support? You can reference this forum thread there.

We would need to start with inspecting IDE logs. You can generate them by running Help > Collect Logs and Diagnostic Data.

0
Comment actions Permalink

Is that the right thing to do? I clicked the "send report with log" button on the first couple of occasions but then stopped because it might irritate somebody particularly if that somebody already has it on their list-of-to-do's. If you think its ok, I'll gladly do as you say.

Bill

0
Comment actions Permalink

ok, I've just reported it on the link you gave me.

many thanks, Bill

0
Comment actions Permalink

> I clicked the "send report with log" button on the first couple of occasions but then stopped because it might irritate somebody particularly if that somebody already has it on their list-of-to-do's.

 

It's ok to send reports each time you get them :) You're not irritate anyone, reports are collected & stored in our system and then processed in a batch manually.

And thanks for reporting, our team will look into this.

0
Comment actions Permalink

I get this same error many times a day.  For example see error report 8109448.

"java.lang.Throwable: Slow operations are prohibited on EDT. See SlowOperations.assertSlowOperationsAreAllowed javadoc."

It happens with multiple different stack traces.  I've already sent 26 reports of this under this account and many dozens more before that when I wasn't signed in into the IDE.  

The IDE quickly needs a global option to shut off, or to be silenced when it's repeated.  It's very very aggravating.

0
Comment actions Permalink

An issue about it: https://youtrack.jetbrains.com/issue/WEB-52144
The notification can be disabled at Help | Find Action | Registry | ide.slow.operations.assertion.

2
Comment actions Permalink

Thanks very much!!  I found the option and will test it.

0

Please sign in to leave a comment.