Keyboard shortcuts in Terminal (can't expand bash alias)

I am using Linux and I have a bunch of aliases in my ~/.bashrc. Those aliases work normally in PhpStorm's terminal. However I can't expand them like I do in other terminals outside of phpstorm.

There is a default hotkey Ctrl+Atl+E to expand an alias, but it is not fired inside phpstorm. I addded one more hotkey (Ctrl+Atl+A) to my ~/.inputrc and this shortcut also fails while in other terminals it works. In IDE keymap settings I removed both shortcuts from all actions where they were bound so that they should not be intercepted by something else. But still alias expansion doesn't work in phpstorm's terminal.

Any ideas?

3 comments
Comment actions Permalink

There is no special meaning that I am aware of but a quick search reveals several reports with the non-working Alt key in the terminal, f.e.:

https://youtrack.jetbrains.com/issue/IDEA-260165 (should be fixed in 2021.2)
https://youtrack.jetbrains.com/issue/IDEA-208225

And a fresh new and seems to be related to national keyboards:
https://youtrack.jetbrains.com/issue/IDEA-271777

1
Comment actions Permalink

Just a wild guess, but do you have an "Override IDE shortcuts" option enabled in "Settings/Preferences > Tools | Terminal"?

0
Comment actions Permalink

Just a wild guess, but do you have an "Override IDE shortcuts" option enabled in "Settings/Preferences > Tools | Terminal"?

Of course it is enabled. And anyway I removed all conflicting shortcuts.

UPD: Just added one more shortcut to .inputrc, namely Ctrl+A without Alt, and it works! 

Just wondering, does Alt have some special meaning in PhpStorm and prevents shortcut from being fired? 

0

Please sign in to leave a comment.