MySQL connection timeout

Hi,

I am using Database feature to connect to MySQL. But it keeps prompting me password every few minutes inactive. How do I disable it permanently ? I want to stay connected as long as I want to.

I used MySQL Workbench in the past and it works exactly what I expect. it stays connected forever. I can go back and run query anytime to compare with my development result. How can I do same in Intelij? 

 

Thanks

2 comments
Comment actions Permalink

hi, please check in File | Settings | Appearance & Behavior | System Settings | Passwords  that is set to 'save passwords', and if so and you are using some native keychain, please try to switch to 'keepass' and let me know if it helps.

0
Comment actions Permalink

As for the connection to MySQL database, I found MySQL C++ connector. It helped to stay connected with database directly.

0

Please sign in to leave a comment.