Issue with Unit of measure px is redundent

I've picked up a project with a lot of legacy CSS etc. in it. The code inspection keeps nagging about Unit of measure px is redundant. 

Doing a find / replace for <space>0px; worked well for half the nags. 

That left instances like padding:  10px 0px 10px 12px;

A find and replace on <space>0px<space>    replaced with <space>0<space>

replaced most of those issues but for some reason the find and replace  then removed the spaces in between the other values. So the above example ended up as padding:  10px 010px 12px;

Why is it reformatting values when the replace explicitly kept the spaces? 

 

2 comments
Comment actions Permalink

Doesn't happen to me, replacing works as expected

Please record a screencast that shows what's happening

0
Comment actions Permalink

It looks like an issue where the css has no commas between parameters. It is producing an error which is still not resolved by addding commas as rgb inspection doesnt allow 4 paramters. see my next ticket.

 

0

Please sign in to leave a comment.