IntelliJ Runtime is Not Available in the Running Plugin Instance

Answered

Hi,

I am trying to implement a feature using JCEF. But the issue is when I run the plugin project, I get a warning saying need to consider switching the JDK. Also I observed that JetBrains runtime is not available in the running instance.

And also when I initiate my feature, it is throwing a error saying JCEF is not available.

java.lang.IllegalStateException: JCEF is not supported in this env or failed to initialize
at com.intellij.ui.jcef.JBCefApp.getInstance(JBCefApp.java:238)

I am using IntelliJ 2021.1.3 in Linux (CentOS 7). Following is the details of my base IDE.

IntelliJ IDEA 2021.1.3 (Community Edition)
Build #IC-211.7628.21, built on June 30, 2021
Runtime version: 11.0.11+9-b1341.60 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Linux 3.10.0-957.el7.x86_64
GC: G1 Young Generation, G1 Old Generation
Memory: 750M
Cores: 2

Kotlin: 211-1.4.32-release-IJ7628.19
Current Desktop: GNOME-Classic:GNOME

Following is the details of the host IDE (with plugin installed)

IntelliJ IDEA 2021.1.3 (Community Edition)
Build #IC-211.7628.21, built on June 30, 2021
Runtime version: 11.0.12+7-LTS amd64
VM: OpenJDK 64-Bit Server VM by Amazon.com Inc.
Linux 3.10.0-957.el7.x86_64
GC: G1 Young Generation, G1 Old Generation
Memory: 512M
Cores: 2
Kotlin: 211-1.4.32-release-IJ7628.19
Current Desktop: GNOME-Classic:GNOME

Note: JCEF functionality is working fine when I build the plugin and installed it to the IDE. Also I tried re-installing the IDE several times as well.

Appreciate any help to fix this issue which would save lot of time for debugging.

2 comments
Comment actions Permalink

Did you configure custom runtime in runIde {} target?

 

PS: Please do not crosspost between Slack and this forum.

0
Comment actions Permalink

Hi Yann Cebron: Thanks for looking into this. I was able to fix this issue and updating this thread with the fix.

The issue was, I was using an older version of `org.jetbrains.intellij` plugin and when I upgrade it to `v0.7.2` it worked fine. Better to use the latest version available to avoid any issues like this.

Thanks! 

0

Please sign in to leave a comment.