Unable to use breakpoints & missing line runner arrow

Hello,

I was working on my project in Webstorm and as far as I can tell - didn't do anything unusual.

Suddenly, I'm unable to set any breakpoints, the green arrows of the line runner are missing, and my Chai tests changed decoration (they are now in yellow text, like functions). 
I've checked the settings and everything is permitted, the code and tests are running fine and there aren't any errors.

I've tried different repos as well, and it's the same.
How can I fix this?
Thank you.

2 comments
Comment actions Permalink

Could you share screenshots illustrating the issue? I need a screenshot of the editor + screenshot of the project tree (Project tool window) with the files you have problems with

0
Comment actions Permalink

Good morning,
I turns out that the problem was that my files weren't associated with TS, so the editor read them as .txt files (I don't know how it got changed to .txt).
It was solved by right-clicking on the file and setting the file type to .ts.
Thank you!

1

Please sign in to leave a comment.