Vim emulation and Ctrl-Up Ctrl-Down for "Next Method Overload"

Answered

When choosing a class that has multiple Ctors, I get prompted with a dialog of choices between then once I type the (). The dialog has a prompt at the bottom that says Ctrl-Up or Ctrl-Down will switch between these items. I must either turn off Vim emulation to be able to type Ctrl-Up/Down or Space-Space and type out the whole "Next Method Overload" and click it to have it swap the options. 

Is this by design, or am I doing something wrong? 

 

0
4 comments

Looks like a bug. I've asked the responsible developer to comment.

1

You can change the shortcuts:

0

What's specifically wrong with Crrl-Up or Ctrl-Down? Why don't they work when Vim emulation is on?

0

Hi, that seems to be a bug in IdeaVim implementation. I've created a bug for this, we'll investigate this. https://youtrack.jetbrains.com/issue/VIM-2398

0

Please sign in to leave a comment.