Activate Virtual Environment in Terminal

Hello,

PyCharm used to automatically activate the virtual environment when opening the terminal window, but not anymore and I have to activate it manually!

This is a fresh install of 2021.2.1.

4 comments
Comment actions Permalink

Hello, 

Please upload your logs folder zipped from ***Help | Collect logs and Diagnostic Data***   to the FTP

https://uploads.jetbrains.com/ and please let me know the filename.  Also, please attach a screenshot of the

Terminal settings https://www.jetbrains.com/help/pycharm/settings-tools-terminal.html and Project Interpreter. 

0
Comment actions Permalink

Hello,

The file is uploaded and the name is "pycharm-logs-20210909-200132.zip".

 

 

 

Right now when I click on "Terminal", it opens and I see the PowerShell prompt not the virtual environment prompt. It wasn't like this before.

0
Comment actions Permalink

Hello, 

 

Please put cmd.exe in the shell field in the terminal setting and reopen the terminal. 

0
Comment actions Permalink

Thanks. Problem solved.

0

Please sign in to leave a comment.