Rails configuration with docker-compose remote sdk fails

Hello, so I configured my docker-compose integration like in this tutorial, but I have an error :

ERROR: Duplicate mount points: [/home/mathis/nemoweb:/nemoweb:rw, /home/mathis/nemoweb:/nemoweb:rw]

I founded when trying to launch the same command as RubyMine, but removing some arguments, that it was caused by the docker-compose.override.[number].yml file generated by RubyMine. Without it, it works perfectly.

Here's my configuration :

Of course, I tried restarting my computer and run docker-compose down.
Nothing changed.

Does anyone know how to solve this problem? thanks



would it be possible to provide a project sample for reproduce (you can use the sample from the tutorial and change it according to your project)?


Hello, I don't think there will be any need for that: I've found the problem. The docker-compose.override file adds the volume "/home/mathis/nemoweb:/nemoweb:rw", while it already exists in my original docker-compose. Nevertheless, it doesn't give me the solution. How to make the docker-compose.override not add this volume?


Hello Kyrela,

Could you check if it helps to comment the volume in the original docker-compose.yml file? Sure it's not a solution, just workaround while we investigate and fix the problem.



Of course I already tried it. Well, it avoids this mistake. but I have another problem : the docker-compose.override.yml also changes the ruby binary location apparently :

app_1      | /usr/local/bin/ruby: No such file or directory -- /home/mathis/nemoweb/bin/rails (LoadError)

Of course, this error does not happen if I run `docker-compose up` from the command line.

Moreover it doesn't solve my problem; it's a file tracked by git, I can't afford to take the risk of pushing it by accident.


Could you please submit an issue on our tracker providing if possible a project sample for reproduce: 



Please sign in to leave a comment.