[SOLVED] Cannot find keymap "Windows Proper Redo"


When starting GoLand (nightly and stable) I get the error

Cannot find keymap "Windows Proper Redo"

It does not prevent or hinders anything AFAICT, and the Search for Windows Proper Redo Keymap plugin hint does not lead anywhere.

How to fix this message?



Feel free to follow IDEA-237237.

Please also attach the following files to the ticket:

  • idea.log (Help | Show Log in Explorer)
  • C:\Users\<username>\AppData\Roaming\JetBrains\GoLand2021.2\keymaps\Windows Proper Redo.xml

I uploaded idea.log - the Upload id: 2021_09_20_8gLNjvZYwGpmZLxH (file: idea.log)
The directory keymaps does not exist on my system (and therefore - Windows Proper redo.xml neither). I guess that it means I cannot try the workaround in the IDEA you mentioned.



Do you have GoLand2020.3 or GoLand2021.1 directories on your system under C:\Users\<username>\AppData\Roaming\JetBrains? If so, do they contain the keymaps directory? What keymap is configured under File | Settings | Keymap? Does it help if you create a file manually with the following content?

<keymap version="1" name="Windows Proper Redo" parent="$default">
  <action id="$Redo">
    <keyboard-shortcut first-keystroke="shift ctrl z" />
    <keyboard-shortcut first-keystroke="shift alt back_space" />
    <keyboard-shortcut first-keystroke="ctrl y" />
  <action id="EditorDeleteLine" />

Do you have GoLand2020.3 or GoLand2021.1 directories on your system under C:\Users\<username>\AppData\Roaming\JetBrains? If so, do they contain the keymaps directory?

Yes I do (C:\Users\WoJ\AppData\Local\JetBrains\GoLand2021.2), it does not contain the directory keymaps.

What keymap is configured under File | Settings | Keymap?

It is Windows. I did not change anything in that setting, so it must be the default one.

Does it help if you create a file manually with the following content?

What should be the filename of this file? (I suppose that I have to manually create the directory keymaps first, and place it over there).

I tried with C:\Users\WoJ\AppData\Local\JetBrains\GoLand2021.2\keymaps\Windows Proper Redo.xml but it did not fix the issue (the error still appars)


Could you please export the IDE settings via File | Manage IDE Settings | Export Settings and upload them to https://uploads.jetbrains.com/, then provide its ID? I'll take a look at what we can do in your case.


(...) then provide its ID? I'll take a look at what we can do in your case.

Thank you. The ID is: 2021_09_21_Rugun1ooFBEwkNnt (file: settingsGoland.zip)


I've found a workaround that might work in your case:

  • Navigate to File | Settings | Plugins and install macOS For All keymap (or any keymap).
  • Switch from Plugins to Keymap tab and change it to macOS For All.
  • Close the IDE and open it again.
  • Change keymap to your back, save changes and delete macOS For All keymap.

Does it help?


Does it help?

Yes it does, thank you very much! (on the stable and nighly version)



Thank you. Works for me as well. Don't know how I managed to change keymap in the first place. It's always been "Windows" for me; I wasn't even aware one /could/ change keymaps.


Android Studio Dolphin | 2021.3.1 Patch 1
Build #AI-213.7172.25.2113.9123335, built on September 30, 2022
Runtime version: 11.0.13+0-b1751.21-8125866 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 11 10.0


I've encountered the same problem recently, but I found a solution that worked for me. Simply press "Ctrl+Y" and then click on the "Redo" option in the popup menu. Everything is functioning properly now.


Please sign in to leave a comment.