CLion with Unreal Engine on Linux

Hi!

I am wondering what is supposed to be the correct way of using CLion with Unreal Engine on Linux? (While waiting for the Linux version of Rider for UE - hope to have that soon!)

I've made several different attempts, but did not even manage to get the project started even once.

Versions: CLion 2021.2.2 manually installed to /opt/clion on Ubuntu 21.10 preview; also tried with the same CLion version installed through the toolbox (with a symlink to the actual installation at /opt/clion/bin/clion.sh). Unreal Engine: 4.27 from GitHub.

What I tried:

./Setup.sh ; ./GenerateProjectFiles.sh ; make
Engine/Binaries/Linux/UE4Editor

Then I'm creating a new C++ project, let's call it MyProject.
UE will not open the editor, but terminate (with Blueprint-only projects the editor opens just fine; also tried with CLion removed - then the editor also opens!)

When opening the editor again and trying to open the project, I get "The following modules are missing or built with a different engine version" with a new project" for MyProject. After confirming, it continues briefly, just to fail with "Engine modules are out of date, and cannot be compiled while the engine is ruining. Please build through your IDE."

Okay, so I've opened it with CLion. I selected it to be a CMake project and confirmed the suggestion for the build target "Debug".
Then it's getting unclear - what do I need to build?

  • When building all or FakeTarget, it will get stuck in "Scanning dependencies of target FakeTarget" forever (first, all cores are busy, but in the end, just one endless process seems to be left).
  • I've also tried to build the target UE4Editor - this seems to rebuild the whole engine. Doesn't change anything though.
  • I've tried make on the command line (tried "make" and "make UE4Editor"), but don't get any binaries and the result won't change.

So essentially, I can't get the project to compile (because I don't know how), and I can't open the editor - probably because I can't get the project to get compiled. I don't know if I'm just lacking an important step, doing something completely wrong, or if there's maybe actually something wrong.

Is there any step-by-step instruction for how it is supposed to be working? I'm aware of Unreal's wiki, however, the instructions I found stop pretty much after building the engine (which works fine), and only explain how to open a project from the command line (which works fine up to the point it tries to build modules...)

Thanks for any hint!

2
1 comment

Don't know if it will help, but for "Engine modules are out of date, and cannot be compiled while the engine is ruining. Please build through your IDE." try this : https://wiki.archlinux.org/title/Unreal_Engine_4#Engine_modules_are_out_of_date,_and_cannot_be_compiled_while_the_engine_is_running._Please_build_through_your_IDE 

I didn't try recently, but at the end I never success compiling from CLion, but still everything else seems to work and I can compile the project from UE itself (It was with 4.26, and now I begin to switch to 4.27 so I will give it a try again), here the post on UE forum :
https://forums.unrealengine.com/t/compiling-game-with-clion-on-ue-4-26-on-linux-some-definitions-disabled-and-apple-headers-missing/225367 

0

Please sign in to leave a comment.