jarFiles is not set for PluginDescriptor

Answered

I just started testing my plugin under the 2021.3 EAP, and when I run my tests I now get the following error:

ERROR: jarFiles is not set for PluginDescriptor(name=Grazie, id=tanvd.grazi, descriptorPath=plugin.xml, path=~/dev/cursive/sdks/213.3714.440-EAP-SNAPSHOT/plugins/grazie/lib/grazie.jar, version=213.3714.440, package=com.intellij.grazie, isBundled=true)

This worked fine under 2021.2. I searched around and found some related YouTrack issues, which seem to have been resolved in this commit: https://github.com/JetBrains/intellij-community/commit/03b7fb1472e4cf789dd777ed4f03a51b6db332eb. However I don't understand what that fix is doing, or what the implication is for me. Is there any way I can diagnose this further?

I run my tests using a test runner which just uses my IntelliJ project classpath.

3 comments
Comment actions Permalink

Please set VM property idea.force.use.core.classloader=true

1
Comment actions Permalink

Thanks, that works for me! For reference, adding this to build.gradle.kts works:

tasks.test {
systemProperty("idea.force.use.core.classloader", "true")
}
0
Comment actions Permalink

Please upgrade to Gradle IntelliJ plugin 1.2.0 or later which fixes this automatically

1

Please sign in to leave a comment.