CLion Error -- The C Compiler is not able to compile a simple test program

Answered

I'm not exactly sure why I'm having this issue; I'm trying to open a project that I've been working on for a while and just today has been the first instance of this issue.

Some background: this project is for a CS class in university, where the CS professor provides us with the files that we need and then we just need to write the code inside the given files.  I'm getting the following error on running the code:

I'm having a hard time even knowing what this means nor how to fix it.  I tried deleting CLion and reinstalling, I've tried moving directories because some of the posts I read say that the directory must have all Latin characters (which I don't see why it wouldn't), and tried redownloading the file from the page we get it from.  I'm at a loss of what else I can do.

Any help would be greatly appreciated!

1 comment
Comment actions Permalink

Hello!

Please install Xcode command line developer tools and configure a toolchain in CLion as described in https://www.jetbrains.com/help/clion/quick-tutorial-on-configuring-clion-on-macos.html.

0

Please sign in to leave a comment.