[regressed] How to prevent this list overflow hover (whats-it-called?) from freezing my CPU?


1. What is this called (for a better topic title)?

2. How do I prevent it from freezing my CPU*? I believe it's the transparency effect that's actually causing the freeze, as some other transparency effects in different applications also rarely freezes my CPU, but hovering over 4-5 of these truncated list items will freeze with a very high probability. It took me over 15 minutes just to make this screenshot.

* A 'CPU freeze' is a freeze of one of the cores for 60 seconds (until some kernel watchdog takes control and resolves it). Because it happens so very often with these transparent hover effects, my work efficiency drops to 1/20th at times. Sometimes it freezes for much longer (I've had it freeze for 6 minutes and 9 minutes) probably because mouse movements were still being recorded and played back after one freeze was over, causing serial freezes.

Solutions I'm looking for:

  • A setting/registry to disable it,
  • A setting/registry to disable the transparency effect,
  • A setting/registry to increase the delay (which is now near-zero).

What I'm not looking for:

  • Turning off the date/size info (as this freeze also happens with directories and in e.g. the thread list),
  • Changes to OS or PC. At the risk of making this an X-Y question. I run Linux and I have an nVidia GPU. These are known to be mortal enemies.

Version of IDEA doesn't matter, it's not a bug in IDEA after all. I am open to working with any version between 2020.1 (i.e. downgrading) and EAP, if that matters.


I could attach logs, but as it's not IntelliJ related, it's not interesting. Here's the gist of it:

Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841876] watchdog: BUG: soft lockup - CPU#7 stuck for 22s! [Xorg:1502]
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841938] RIP: 0010:iommu_unmap_page+0xb8/0x100
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841940] Code: 00 00 48 29 c1 31 c0 48 d3 e2 48 c7 04 c6 00 00 00 00 48 83 c0 01 39 c2 7f f0 48 8b 45 c8 48 89 c2 49 01 c7 48 f7 da 4c 21 f2 <4c> 39 fb 4c 8d 34 10 77 91 4d 85 ff 75 23 48 8b 7d d0 65 48 33 3c
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841941] RSP: 0018:ffffbd66c1bf79a8 EFLAGS: 00000206 ORIG_RAX: ffffffffffffff13
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841942] RAX: 0000008000000000 RBX: 0000000000001000 RCX: 0000000000000027
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841943] RDX: 0000860000000000 RSI: 0000000000000000 RDI: 0000000000000000
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841944] RBP: ffffbd66c1bf79e0 R08: ffffbd66c1bf79a8 R09: 0000000000000004
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841953] __unmap_single.isra.27+0x66/0x130
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.841955] unmap_sg+0x5f/0x70
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.842106] nv_unmap_dma_map_scatterlist+0x57/0xa0 [nvidia]
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.842248] nv_dma_unmap_pages+0x56/0x100 [nvidia]
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.842389] nv_dma_unmap_alloc+0x16/0x30 [nvidia]
Sep 28 18:49:05 zomb-pc-2019 kernel: [2090646.842583] _nv032984rm+0xc1/0x1b0 [nvidia]

Note that it always claims 22s even though it's always 60 seconds (or whereabouts).



This looks like kernel/nvidia driver issue. Did you try using different kernel/GPU driver versions? This should be reported to your OS maintainers.


I tried different drivers. The drivers are also updated every 2 weeks or so, and this issue has been plaguing me since I have this PC (2y). And I'm not the only one with this problem, and there doesn't seem to be a solution. If anything, it's getting worse with time.


At this point, I'm just hoping there's a setting or registry inside IDEA that can help me.


You can try -Dremote.x11.workaround=true in Help | Edit Custom VM Options. Restart the IDE. It should disable all transparency effects.


Thanks, big man.

Apart from lots of visual glitches (like icon badges obscuring the icons) the freezes seem to have stopped!


Now just for how these things are called...


Java thread dump may help to understand better what code triggers the problem, see https://intellij-support.jetbrains.com/hc/en-us/articles/206544899. You can use jstack while the issue occurs.


Serge Baranov I'm once again asking this because since the last few versions (maybe half a year or so) It started freezing regularly again.

I'm still using the `-Dremote.x11.workaround=true` option, but I realized lately that I don't see any visual glitches anymore. The freezes are also not as frequent as they used to be, or maybe I'm imagining it, because just now I had two subsequent freezes, both when I moved the mouse from the editor to the menus, passing the file list with lots of truncated entries on the way.

The lack of visual glitches didn't initially ring a bell because 1) The glitches may have been fixed, and 2) even last year when I just started using the flag, there were still some transparent elements left, like the variable value pop-up in debugging.

Do you have any idea how to solve this issue from here on?


YouTrack ticket with the thread dumps would be appreciated.


Scroll up a bit for the Nvidia stack dump. YouTrack would be off-topic for this.


`Dremote.x11.workaround=true` worked in 2021.2.4, doesn't work in 2021.3 RC. I'm staying with 2021.2.4 for the time being.

[Edit] narrowed it down slightly more. It worked in 213.3714.440.


Sorry if it was not clear. Please report at https://youtrack.jetbrains.com/newIssue?project=IDEA with the thread dumps attached per https://intellij-support.jetbrains.com/hc/en-us/articles/206544899. Stack dump != thread dump.


Please sign in to leave a comment.