Unable to type on editor when using TypedActionHandler?

Answered

Hello,

I'm using TypedActionHandler to execute an action as the user types. Implemented accordingly as shown in the document, but when I run the task I'm unable to type on the editor. The UI doesn't freezes up, also I do not get any exceptions. I'm unable to understand the issue. Can you please help me to resolve this issue.

Also, can I count the number of keystrokes as user types using TypedActionHandler?

3 comments
Comment actions Permalink

Please share your code

0
Comment actions Permalink

I just followed the sdk documentation, TypedActionHandler is not allowing me to type in the editor.

https://plugins.jetbrains.com/docs/intellij/editor-events.html#creating-a-custom-typedactionhandler

So, I used TypedHandlerDelegate which actually worked. Is that right approach?

Also, I would like to know is there a way to get the count of keystrokes using typedHandlerDelegate or any other approach?

0
Comment actions Permalink

If the solution with TypedHandlerDelegate works, then it's fine

It should be possible to count the total number of keystrokes using TypedHandlerDelegate, but obviously this includes _any_ keystrokes.

0

Please sign in to leave a comment.