Webstorm run on port 4200

Hi,

when I start Webstorm (v. 2021.2.2) it starts on port 4200 and so I can't run ng-serve on the same port. If I kill the task 4200 Webstorm closes.

Even with new projects. It has always worked well, I don't remember having done any updates.

Thanks

3 comments
Comment actions Permalink

You must have done by by mistake. I've seen it quite a few times in the past ("hey, it says "port number" on it.. and it not what I'm using..."). This can easily happen if something does not work straight away and you look everywhere trying to change everything hoping "it has to be this one" without checking the docs first ("I'll figure it out on my own").

 

Please set it back to the default 63342 and restart the IDE.

This port is used by the IDE for internal comms, built-in web server, debugger integrations etc. and should only be changed in some rare cases where user clearly know how it works/what that is for.

2
Comment actions Permalink

Hi there,

Please show what you have at "Settings/Preferences | Build, Execution, Deployment | Debugger"

1
Comment actions Permalink

I had 4200!

Thank you very much (I don't know how that value got reset...)

0

Please sign in to leave a comment.