Go autocomplete not working

Completed

Without upgrading or installing anything autocomplete just stopped working. It also doesn't suggest any imports, recognize any of the imported functions.  It's running like it doesn't recognize the Go language at all.

4 comments
Comment actions Permalink

Hello Rich,

Could you please upload the IDE logs (Help | Collect Logs and Diagnostic Data) to https://uploads.jetbrains.com/ and provide its ID? Are you using Go modules or GOPATH? A screenshot with your file would be helpful too.

0
Comment actions Permalink

Hi Uploaded: Upload id: 2021_10_12_S6r7zMhXpAKNWpaC (file: goland-logs-20211012-105015.zip)

declare -x GO111MODULE="auto"
declare -x GOBIN="/Users/rx7322/go/bin"
declare -x GOPATH="/Users/rx7322/go"
declare -x GOROOT="/usr/local/go"
declare -x _INTELLIJ_FORCE_SET_GO111MODULE="auto"
declare -x _INTELLIJ_FORCE_SET_GOPATH="/Users/rx7322/go"
declare -x _INTELLIJ_FORCE_SET_GOROOT="/usr/local/go"

0
Comment actions Permalink

So, your IDE configuration looks correct. Could you please update the IDE to the latest version (GoLand | Check for Updates), disable 3rd-party plugins via Preferences | Plugins | Installed, then provide a screenshot with your project tree inside the IDE and the opened file in the editor area where autocomplete isn't working?

0
Comment actions Permalink

So I disabled all the plugins -- restarted. It autocompletes. So I just went in and enabled only the plugins I wanted to use.  Thanks!

1

Please sign in to leave a comment.