how to fix this bracket completion -> ())

I don't know how to do a search, so I apologize if this has been asked before.

I don't remember this being the case before, but at some point it started to appear twice when I typed in closing brackets.

 

ex)
"(" input -> "()" output
"()" input -> "())" output    # I want it to be "()" in this case too.

 

Is there any settings place to modify this behavior?

2 comments
Comment actions Permalink

Usually, you can configure paired brackets in Preferences | Editor | General | Smart Keys, but I don't know any cases when it would print the duplicated bracket. 

I would suggest to try disabling all custom plugins.

If this doesn't help, then you could check with default IDE settings.

You can reset IDE settings to default by using **File | Manage IDE settings | Restore Default Settings...**. Your current settings will be backed up, so you can revert to them later (to do this, just import settings from the backed up folder).

1
Comment actions Permalink

Thank you for your comments.

 

As you told me, I tried disabling all custom plugins, and it worked!

Now all plugin settings are same as before, but no more duplicated bracket.

Problem has solved, thank you.

0

Please sign in to leave a comment.