Debugging a plugin doesn't work - no plugin code is loaded.


I'm developing my first plugin using the IntelliJ DevKit toolset and I'm not able to debug any developed features.  I currently have defined a custom action, put it in a group and have it open a dialog but when I debug it using the following debug config my plugin isn't loaded:

The plugin itself is valid because when I "prepare for deployment" and then copy/paste the jar into the plugin folder of my IntelliJ and restart it, it does exactly what I expect it to do.  It shows my menu item and when I click it, my code is executed and my dialog is shown:

You can find the entire sourcecode of my plugin here: (incl. the .idea folder).

IntelliJ version:

IntelliJ IDEA 2021.2.2 (Ultimate Edition)
Build #IU-212.5284.40, built on September 14, 2021
Licensed to -redacted-
Subscription is active until December 23, 2021.
Runtime version: 11.0.12+7-b1504.28 amd64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
Windows 10 10.0
GC: ParNew, ConcurrentMarkSweep
Memory: 8125M
Cores: 8
Non-Bundled Plugins: com.intellij.plugins.html.instantEditing (212.4746.57), org.intellij.scala (2021.2.17), Struts Assistant (192.9)
Kotlin: 212-1.5.10-release-IJ5284.40

Project SDK info:

If there's any other info you need, let me know.



Comment actions Permalink

Please use Gradle build system for building plugins for IntelliJ-based IDEs:

There's also IntelliJ Platform Plugin Template available for speeding up the setup process:

Comment actions Permalink

I suspected this would be an answer.  I tried it with Gradle using the template but couldn't get anything to work. It took me 5minutes of using the DevKit way to have a working plugin.  I'm just not able to debug it.

Comment actions Permalink

I can really recommend the switch to gradle. It takes some time to correctly setup everything, but once its done, everything worked perfectly and as expected.

Comment actions Permalink

I will look into it next time but this doesn't change the fact that the DevKit way is still possible and provided in the UI.  So it should still be possible to debug my plugin...


Please sign in to leave a comment.