Angular 13 and message "Cannot resolve symbol" for <router-outlet>

Hi,

after updating to Angular 13, WS (v. 212.5457.55) reports in red "<router-outlet>" and "pipe"s with messages: "Cannot resolve symbol" and "Unresolved pipe date".

The application works perfectly and no errors are reported during build.

Do I need to change any settings?

Thanks

9 comments
Comment actions Permalink

having the same issue on a new project I just created

4
Comment actions Permalink

Same problem here after upgrading my project to Angular 13.
I'm using IntelliJ 2021.2.3 (Ultimate Edition) Build #UI-212.5457.46

1
Comment actions Permalink

Same issue after upgrading to Angular 13 running: 

IntelliJ IDEA 2021.2.3 (Ultimate Edition) Build #IU-212.5457.46, built on October 13, 2021

Confirmed still an issue on the latest EAP build

IntelliJ IDEA 2021.3 Beta (Ultimate Edition) Build #IU-213.5605.12, built on November 3, 2021



2
Comment actions Permalink

This is also an issue for me. Angular 13 but I'm in Rider instead of IntelliJ. There's something wrong. RouterModule is imported in app.module.ts but still cannot resolve symbol router-outlet in app.component.html

Please fix!! This is a serious issue.

0
Comment actions Permalink

Philbusiness52 this is fixed in the latest RC build.

0
Comment actions Permalink

I too have the same issue. Gives error in HTML (unresolved pipe date) but works fine

 

0
Comment actions Permalink

Angular 13 is supported since 2021.3. If it's still an issue for you in current version (2022.x), please submit a ticket to youtrack, https://youtrack.jetbrains.com/issues/WEB

0
Comment actions Permalink

Still an issue. Annoying.

0

Please sign in to leave a comment.