Clion not sync local file to remote server after changing deployment's root path and deployment path


CLion version :  2021.2.3   , local machine:64 bit Windows 10,  remote server: Linux version 3.10.0-1160.42.2.el7.x86_64, CMake: 3.17.3

When I first run Clion with my project checked out from github on my local machine (Windows 10), for deployment,  Clion assigned a default root path as / ( linux  root directory) and a randomly generated deployment.path tmp.LUhtX8KW3f. So local files get uploaded to remote server vi SFTP.  

One or two days later, I decided to change the root path to my Linux home directory as /home/my_username.  So local files got uploaded to the new directory on remote Linux  server.  However, after I checked out some source code from github (to pick up bug fixes), some files (with fixes) were NOT uploaded to the NEW deployment path (under my Linux home directory) on remote server, instead, they were uploaded to the original deployment path (under Linux root directory /). 

Can anyone please advise ?  It is my first time to use CLion, did I miss anything?  It is blocking my development pretty badly.  Is there any  way to reset CLion state to start clean (except removing some project management data from  AppData or even uninstall/reinstall).




How many deployment configurations do you have now in File | Settings | Build, Execution, Deployment | Deployment? Did you change the deployment path in the existing configuration or did you create a new configuration?


Hi, Anna,

I have only one configuration. In other words, I changed both root path and deployment path in the existing configuration. 



That's strange. Could you please do `Tools | CMake | Reset Cache and Reload Project`? Does it help?


I did it that step. But it didn't help.

Here is more details :

1. after initial upload (after I changed the root path and deployment path in the same configuration), I tried remote build. And it failed due to some bugs in code under one directory (let's call it FooTest).

2.then I did git checkout locally (on Windows) to pick up the bug fix from github. That's when I noticed the big fix wasn't "uploaded" to remote server. 

3. I then tried to exclude the FooTest directory  from CLion.  For some reason, when click "build" from CLion, it still tried to compile the code under FooTest ( supposed to be excluded).   And it failed, as the newer version wasn't at the remote server.

4.  I then un-exclude FooTest diretory from CLion. To my surprise, it was still listed under Setting --> Deployment --> particular configuration --> Excluded Path. I had to manually remove FooTest here.

5. On Windows, I then tried to removed local CLion project directory "CLionProjects",  and AppData/Local/JetBrains/CLion2021.2, clone the same project from github, to my surprise,  the deployment's configuration is still there. 

6. I then uninstall/reinstall CLion, after removed local CLion project directory "CLionProjects",  and AppData/Local/JetBrains/CLion2021.2. clone the project from github once more. And the deployment configuration is still there ( is it stored in registry?) . I then deleted the configuration and re-added, this finally did the trick.

7, So I suspect CLion's state was somehow messed up when I first changed the root path and mapped path. It could be caused by my prematurely terminated the uploading or did multiple uploading. As the window doesn't show much activities. You have to pay attention to the bottom progress bar ( not obvious to a newbie).  Deleting and re-adding the deployment configuration seems to clean up the state. 


>And the deployment configuration is still there ( is it stored in registry?)

There are project settings and IDE settings. Toolchains and deployment settings corresponding to remote toolchains are IDE settings.


Where are toolchains and deployment setting being exactly stored?  I removed {MyAccountName}/AppData/local/JetBrains/CLion2021.2 and did un-installation/re-installation of CLion, but the toolchains and deployment setting seem to be able to survive. 


Please sign in to leave a comment.