PHPStorm doing something weird with blank lines and whitespaces

PHPStorm is doing something with blank lines so that they are shown as changes in my commits.

I turned on keep indent on empty lines and turned off remove trailing spaces but it didn't fix the problem. What's going on here?

2 comments
Comment actions Permalink

First of all, I would suggest enabling all "Show whitespaces" options in "Settings/Preferences | Editor | General | Appearance", it should help to catch the change visually.

By the way, do you have any Code Quality tools configured?

0
Comment actions Permalink

The same on StackOverflow: https://stackoverflow.com/q/70009146/783119

P.S. It's .editorconfig file and trim_trailing_whitespace there.

1

Please sign in to leave a comment.