No suggestions

Hi!

I created project from existed files (choose "Web server in on remote host, files are accessible via FTP/SFTP/FTPS")

Installed plugins:

  • Symfony support
  • Doctrine
  • PHP Annotation

After creation objects no suggestions about available methods:

Can tell any ideas for how to fix it? Will be glad.

18 comments
Comment actions Permalink

Just tried with `symfony/form` package, seems to be working fine:

Could you please share a `composer.json` from your project? Do you have anything configured in "Preferences/Settings| PHP > Include Path"?

1
Comment actions Permalink

Thanks for sharing the composer.json.

Actually, I was not able to reproduce the issue with your configuration either. What happens when you Ctrl+Click on "FormBuilderInterface", does it navigate you to the interface definition?

Also, would it be possible to share the reproducible project?

1
Comment actions Permalink

Thanks for sharing the project.

In fact, the issue is not reproducible for me with your project as well (of course, I have installed vendor packages from the composer).

It is a somewhat generic question but have you tried to invalidate caches already?

Just in case:
https://www.jetbrains.com/help/phpstorm/invalidate-caches.html

1
Comment actions Permalink

Do you have a vendor directory locally in your project?

1
Comment actions Permalink

Could you please share the ".idea" folder from your project copy?

1
Comment actions Permalink

I would suggest submitting a support request via the "Help > Contact Support", it will be much easier to communicate and share files within the support ticket.

1
Comment actions Permalink

No worries at all, thank you for sharing the file.

In fact, I was not able to reproduce the issue with your project settings too (just installed composer.json packages). Just to confirm, do you have an "Import class" fix available for `FormBuilderInterface`?

1
Comment actions Permalink

Hi there.

No ideas yet, sorry. I think that we are missing something simple and obvious here.
I was wondering if you could share your project as-is with the "vendor" dir and the file from the sample above. Could you please submit a support ticket with the attached archive and share its number?

1
Comment actions Permalink

Yes, ofcourse.

My `composer.json`:

{
"type": "project",
"license": "proprietary",
"minimum-stability": "dev",
"prefer-stable": true,
"require": {
"php": ">=7.4",
"ext-ctype": "*",
"ext-iconv": "*",
"api-platform/core": "^2.6",
"composer/package-versions-deprecated": "1.11.99.1",
"doctrine/annotations": "^1.0",
"doctrine/doctrine-bundle": "^2.3",
"doctrine/doctrine-migrations-bundle": "^3.1",
"doctrine/orm": "^2.8",
"easycorp/easyadmin-bundle": "^3",
"nelmio/cors-bundle": "^2.1",
"php-webdriver/webdriver": "^1.12",
"phpdocumentor/reflection-docblock": "^5.2",
"sensio/framework-extra-bundle": "^6.1",
"symfony/apache-pack": "^1.0",
"symfony/asset": "5.3.*",
"symfony/console": "5.3.*",
"symfony/dotenv": "5.3.*",
"symfony/expression-language": "5.3.*",
"symfony/flex": "^1.3.1",
"symfony/form": "5.3.*",
"symfony/framework-bundle": "5.3.*",
"symfony/http-client": "5.3.*",
"symfony/intl": "5.3.*",
"symfony/mailer": "5.3.*",
"symfony/mime": "5.3.*",
"symfony/monolog-bundle": "^3.7",
"symfony/notifier": "5.3.*",
"symfony/process": "5.3.*",
"symfony/property-access": "5.3.*",
"symfony/property-info": "5.3.*",
"symfony/proxy-manager-bridge": "5.3.*",
"symfony/security-bundle": "5.3.*",
"symfony/security-core": "5.3.*",
"symfony/security-http": "5.3.*",
"symfony/serializer": "5.3.*",
"symfony/string": "5.3.*",
"symfony/translation": "5.3.*",
"symfony/twig-bundle": "^5.2",
"symfony/validator": "5.3.*",
"symfony/web-link": "5.3.*",
"symfony/yaml": "5.3.*",
"symfonycasts/verify-email-bundle": "^1.5",
"twig/extra-bundle": "^2.12|^3.0",
"twig/twig": "^2.12|^3.0"
},
"require-dev": {
"doctrine/doctrine-fixtures-bundle": "^3.4",
"symfony/browser-kit": "^5.2",
"symfony/css-selector": "^5.2",
"symfony/debug-bundle": "^5.2",
"symfony/maker-bundle": "^1.0",
"symfony/phpunit-bridge": "^5.2",
"symfony/stopwatch": "^5.2",
"symfony/var-dumper": "^5.2",
"symfony/web-profiler-bundle": "^5.2"
},
"config": {
"optimize-autoloader": true,
"preferred-install": {
"*": "dist"
},
"sort-packages": true
},
"autoload": {
"psr-4": {
"App\\": "src/"
}
},
"autoload-dev": {
"psr-4": {
"App\\Tests\\": "tests/"
}
},
"replace": {
"symfony/polyfill-ctype": "*",
"symfony/polyfill-iconv": "*",
"symfony/polyfill-php72": "*"
},
"scripts": {
"auto-scripts": {
"cache:clear": "symfony-cmd",
"assets:install %PUBLIC_DIR%": "symfony-cmd"
},
"post-install-cmd": [
"@auto-scripts"
],
"post-update-cmd": [
"@auto-scripts"
]
},
"conflict": {
"symfony/symfony": "*"
},
"extra": {
"symfony": {
"allow-contrib": false,
"require": "5.3.*"
}
}
}

Do you have anything configured in "Preferences/Settings| PHP > Include Path"?

No. All settings on this tab are default.

0
Comment actions Permalink

1. Not navigate. On hover I can see:

2. Yes, sure:

https://github.com/blink2004/demo-sym 

I deleted some other files which was created by me (few not important Controllers and Entities) and /vendor folder.

 

0
Comment actions Permalink

Thanks, Vasiliy, for the answer.

It's very interesting. I understand that problem is on my computer. 

Yes, I did recommendation at the link before wrote this post. Unfortunately, it didn't helped me.

I thinking I am missing something...

 

The code is located on my computer and FTP-server. PHP and Composer are installed on the server. Maybe some configs? From where take bundles...

0
Comment actions Permalink

Yes, ofcourse. /vendor folder has 28Mb size and I didn't wonna upload to GitHub for save the time.

0
Comment actions Permalink

Project created by next steps:

1.

2. 

 

0
Comment actions Permalink

Yes, not a problem. This folder has many confidential information. Could you please provide any security way for transfer? For example, email.

0
Comment actions Permalink

Sorry for my delayed answer.

I'm uploaded to GitHub .idea folder as RAR-archive - https://github.com/blink2004/demo-sym/blob/main/.idea.rar

Pre-removed sensitivity data.

0
Comment actions Permalink

No...
That is all what I have in context menu:

0
Comment actions Permalink

Hi @Vasiliy Yur,

Maybe you have yet ideas?

0
Comment actions Permalink

Hi,
I'm created request #3718486 with attachment.

0

Please sign in to leave a comment.