Keyboard Shortcut for Go Fmt File (Ctrl+Alt+Shift+F) not working in 2021.2.4


They keyboard shortcut for Go Fmt File (Ctrl+Alt+Shift+F) does not work, however choosing the menu option does format the code.  Additionally, the keyboard shortcut for Go Fmt Project does work.

Is this a known issue?

Thanks in advance


Please, navigate to File | Settings | Keymap, click on the Find Actions by Shortcut icon, then press Ctrl+Alt+Shift+F, close the pop-up and provide a screenshot of filtered results.


Hi Daniil, thanks for the quick response!  Please see the screenshot below.


Thank you. Your keymap configuration seems correct. Please, collect the IDE logs via Help | Collect Logs and Diagnostic Data and upload it to, then provide its ID.


Daniil, looking at the generated diagnostics there appears to be a significant amount of proprietary info collected that I cannot share.  Is there a small section of the info you need that I can either scrub manually or a way to easily generate the needed diagnostics w/out exposing sensitive data?


Sure. I'd like to know a few things that you can find inside the troubleshooting.txt file:

  • GoLand version (at the top of the file).
  • 3rd-party installed plugins.

Does it help if you switch the keymap from Windows Proper Redo to Windows?


I've scrubbed the troubleshooting.txt file and uploaded it:

Upload id: 2021_11_22_Lf8YT6ouhCGcuoYk (file: troubleshooting.txt)

It does not help if I change the keymap from Windows Proper Redo to Windows.  Same result - the shortcut key doesn't work.


Got it. Does reassigning of File | Settings | Keymap | Plugins | PlantUML integration | Update PlantUml Diagrams - changes only to a different shortcut help?


I've re-assigned that to ALT+U and not Go Fmt File (Ctrl+Alt+Shift+F) works.  What's the expected behavior with doubled/triples/quadrupled keymaps? Are they supposed to be context aware to the file type?  Generally one would think that's not good - but the built-in Database Tools and SQL Plugins duplicates it twice.

Couple of other things of note:

  • One of my colleagues has 2021.2.2 with the PlantUML plugin (not sure which version of the plugin) but he doesn't have an issue with Go Fmt File
  • My 2021.2.4 install a migration from an older laptop that was running Goland 2020.1 (old, yes) with the PlantUml plugin appropriate for that version and the duplicate keymap - Go Fmt File worked there.  This version also has the duplicate keymap for database tools and sql, though only for one function.

Not sure what to make of the inconsistency - whether it's a fluke that duplicate/triplicate/quadruplicate keymaps generally seem to work in the first place or there's a bug either in the plugin or ide that is preventing "normally allowed" multiple keymaps from working?




I'd say that it is a bug in the IDE. Thanks for the details. Could you please confirm that it works as expected with two actions to the same shortcut in the EAP version of GoLand (


Please sign in to leave a comment.