Scope editor only sees a small portion of the contents of the/vendor directory

Scope editor only sees only several elements of vendor dir, but there are definitely more in /vendor dir and it is entire vendor dir that ignored in .gitignore, and not the portions of it. Why does scope editor see only part of it and how to include entire vendor dir in scope ?

0
1 comment

Hi there,

That's because this screen does not include folders marked as Excluded.

Settings/Preferences | Directories -- you can check them there.

By default all composer packages will be marked as Excluded and then re-added back as "PHP | Include Path" entry. This allows the IDE to ignore any TODO/errors/etc in excluded folders (that is 3rd party library), exclude usages there from Refactoring etc. while "Include Path" entry still allows the IDE to index those files and offer in code completion etc.

0

Please sign in to leave a comment.