Lowercase intellisense, DDL preview, and list of tables

Answered

I started using Snowflake recently and it drives me nuts that it forces me to look at things in uppercase.

Any chance we can change this:

to lowercase ? As well as list of schemas and tables? I managed to switch it once but only for intellisense for column completion and now it's gone as well.

6 comments
Comment actions Permalink

Set 'Identifiers' to lower too.

1
Comment actions Permalink

It should be here File | Settings | Editor | Code Style | SQL | General -> Case -> set parameters as you like (I guess all to 'lower').

 

0
Comment actions Permalink

This is how I have it:

 

But the list of tables, columns, and intellisense still uses uppercase. I mean uppercase is fine for keywords (as noted in settings) but not columns/tables/schemas/aliases

0
Comment actions Permalink

Thank you, this worked for the intellisense at least. ANy chance it can be done for columns and tables in the list and the results table:

0
Comment actions Permalink

No, this is how it's coming from database and we don't change it.

0
Comment actions Permalink

Thanks Yuriy. such a shame.. Snowflake has a big minus in my world for showing everything as uppercase :D

0

Please sign in to leave a comment.