some jar in idea plugin sdk is low,how to replace?

Answered

hello, i am developing a plugin ,i use lucene-core 8.0.0 ,but  intellij sdk plugins\maven\lib\lucene-core-2.4.1.

though,i append ucene-core 8.0.0  in dependency ,plugin classloader can not load ,throw classnot found exception org.apache.store.directory.  how to resolve this problem? 

5 comments
Comment actions Permalink

when i install my plugin ,i find the proble above .when i am in  debug model ,i only import lucene8.00 and delete 2.4 in idea sdk .

0
Comment actions Permalink

Heu Majing The workaround from the other thread should help. Note that bundled Lucene version in 2021.3 has been upgraded to 8.9.0

0
Comment actions Permalink

Yann Cebron

1、how to unstand this "The workaround from the other thread should help", can you explain ? i guess i will meet samp problem ,eg: intellij sdk has a same name jar ,but i need other version.

2、i use 2020.3 ,lucene version is 2.4.1.

3、i found that the lucene in path: plugins\maven\lib\lucene-core-2.4.1.  but myplugin does not dependency maven ,why it will load the jar in plugins\maven\lib\lucene-core-2.4.1  ,not build.gradle file dependency part?

wish your explain!

0

Please sign in to leave a comment.