Double clicking file in project tree is behaving as the preview tab feature

I recently upgraded from a couple of versions down to the latest version of PHPStorm. After restarting the app I can no longer open multiple files in tabs.

The way it used to work is that I would double click on a file from the project tree and it would be opened in a tab, then I could open a different file and it would open up in a new tab.. now, if I double click on a file it opens in a tab, then I double click another file and it replaces the previously opened file in the tab -- so I can't get multiple tabs open at the same time, it's just that single tab all the time.

Now, if I modify the file in the open tab, and then double click another file, it will open in a new tab.. but this doesn't work for me because it would be a pain to keep modifying files just to have them all opened.

Anyone knows if there's a setting that controls this? I tried enabling and disabling the preview tab feature -- which also doesn't work the way it should anyway.

2 comments
Comment actions Permalink

Thanks Dmitry Tronin, I had already tried options 1 and 2 and didn't work. I just tried option 3 and doesn't work either.

Anyway, I just installed a new update and it fixed this issue.

Thanks!

1
Comment actions Permalink

1) Try disabling Settings (Preferences on macOS) | Advanced Settings | When navigating to a file, prefer selecting existing tab in inactive split pane checkbox.

2) Check if there's a Tab limit at File | Settings | Editor | General | Editor Tabs

3) Please try disabling all custom plugins at Settings | Plugins > click on a gear icon > "Disable All Downloaded Plugins", restart IDE and check the issue after that. 

0

Please sign in to leave a comment.