git menu item gone from file context menu

Answered

There always was a git item in the file context menu between Local History and Reload from Disk.  That menu item is gone. 

The Git menu Select File item has all items in the sub menu disabled.  There is currently no way to access git functionality like Compare and Show History.

0
8 comments

Jakub Please check File | Settings | Version Control | Directory Mappings and see if your project is listed there? 
Probably, in case of a complex project structure, specifying a path to a project would help, instead of using <Project> in that settings

1

Restart your IDE. 

1

Hello Dean Schulze

Does it happen for all files in your project? Do you have multiple repositories in your project?
Are affected files stored in a folder specified in Preferences | Version Control | Directory Mappings?


0

After updating to the 2021.3 version of IntelliJ, I had the same issue that the git context menu entry was gone in my current project. What helped in my case was to go into the VCS menu and again select git as the VCS to use for the current project. IntelliJ seems to "forget" that information during the update.

0

Ulrich Krenn
Have you faced such behavior on all of your projects or only one has been affected?

0

Ruslan Kuleshov

It seems to me that only this single project was affected by the git issue. For all other projects git is still recognized as the VCS to use. But I have to say that the affected project was the one I currently work on and therefore I did not open any other project before all issues in the affected project had worked out...

0

The problem was that my project was one level below the directory where .git/ was and in the Version Control Settings page there were two entries.  One was for one directory up (where .git/ was) and one for my project directory.  Once I removed the entry for the project directory the git context menu showed up normally.

0

I`m having the same issue. On all my projects and I didn't change anything in the structure. 

I`ve already tried reinstalling PHP storm, and reinitializing the repository, I've checked with a new repo, and nothing.

Is there a setting for that or smth?

 

0

Please sign in to leave a comment.