help, could not resolve org.jetbrains.intellij.deps:asm-all:9.2

Answered

hi,  my plugin can not run or debug now. the error is:

Execution failed for task ':instrumentCode'.
> Error while evaluating property 'compilerClassPathFromMaven' of task ':instrumentCode'
> Failed to calculate the value of task ':instrumentCode' property 'compilerClassPathFromMaven'.
> Could not resolve all files for configuration ':detachedConfiguration3'.
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
Required by:
project : > com.jetbrains.intellij.java:java-compiler-ant-tasks:213.5744.223
project : > com.jetbrains.intellij.java:java-compiler-ant-tasks:213.5744.223 > com.jetbrains.intellij.java:java-gui-forms-compiler:213.5744.223
project : > com.jetbrains.intellij.java:java-compiler-ant-tasks:213.5744.223 > com.jetbrains.intellij.java:java-compiler-instrumentation-util:213.5744.223
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
> Could not get resource 'https://dl.bintray.com/jetbrains/intellij-third-party-dependencie/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> Could not GET 'https://dl.bintray.com/jetbrains/intellij-third-party-dependencie/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'. Received status code 403 from server: Forbidden
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
> Could not get resource 'https://dl.bintray.com/jetbrains/intellij-plugin-service/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> Could not GET 'https://dl.bintray.com/jetbrains/intellij-plugin-service/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'. Received status code 403 from server: Forbidden
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
> Could not get resource 'https://maven-central.storage-download.googleapis.com/repos/central/data/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> Could not GET 'https://maven-central.storage-download.googleapis.com/repos/central/data/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> The server may not support the client's requested TLS protocol versions: (TLSv1.2, TLSv1.3). You may need to configure the client to allow other protocols to be used. See: https://docs.gradle.org/7.1/userguide/build_environment.html#gradle_system_properties
> PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
> Could not get resource 'https://cache-redirector.jetbrains.com/www.jetbrains.com/intellij-repository/releases/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> Could not GET 'https://cache-redirector.jetbrains.com/www.jetbrains.com/intellij-repository/releases/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> The server may not support the client's requested TLS protocol versions: (TLSv1.2, TLSv1.3). You may need to configure the client to allow other protocols to be used. See: https://docs.gradle.org/7.1/userguide/build_environment.html#gradle_system_properties
> Received fatal alert: handshake_failure
> Could not resolve org.jetbrains.intellij.deps:asm-all:9.2.
> Could not get resource 'https://cache-redirector.jetbrains.com/intellij-dependencies/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> Could not GET 'https://cache-redirector.jetbrains.com/intellij-dependencies/org/jetbrains/intellij/deps/asm-all/9.2/asm-all-9.2.pom'.
> The server may not support the client's requested TLS protocol versions: (TLSv1.2, TLSv1.3). You may need to configure the client to allow other protocols to be used. See: https://docs.gradle.org/7.1/userguide/build_environment.html#gradle_system_properties
> Received fatal alert: handshake_failure

 

the idea version is 2021.3 (ultimate edition)

the sdk is: IntelliJ IDEA IU-213.5744.223

the build.gradle file:

plugins {
id 'org.jetbrains.intellij' version '1.3.0'
id 'java'
}

processResources{
from('src/main/java'){
include('**/*.properties')
}
}

group 'com.mytest'
version '0.0.4'

apply plugin: 'org.jetbrains.intellij'
sourceCompatibility = 1.8
targetCompatibility = 1.8

repositories {
maven {
url 'https://projects.itemis.de/nexus/content/repositories/OS/'
}
maven {
url 'https://dl.bintray.com/jetbrains/intellij-third-party-dependencie/'
}
maven {
url 'https://jcenter.bintray.com/'
}
maven {
url 'https://www.jetbrains.com/intellij-repository/releases/'
}

maven {
url 'https://dl.bintray.com/jetbrains/intellij-plugin-service'
}
maven {
url "https://oss.sonatype.org/content/repositories/snapshots/"
}
maven {
url "https://maven.aliyun.com/repository/public"
}
maven {
url "https://maven-central.storage-download.googleapis.com/repos/central/data/"
}
maven {
url "https://repo.eclipse.org/content/groups/releases/"
}
maven {
url "https://www.jetbrains.com/intellij-repository/releases"
}
mavenCentral()
jcenter()
gradlePluginPortal()
}

dependencies {
implementation 'com.squareup.okhttp3:okhttp:3.14.9'
implementation ('org.eclipse.jgit:org.eclipse.jgit:5.8.1.202007141445-r') {
exclude group: 'org.slf4j'
}
}

// See https://github.com/JetBrains/gradle-intellij-plugin/
intellij {
version = '2021.3'
plugins = ['java', 'org.jetbrains.idea.maven']
}

runPluginVerifier {
// Plugin Verifier integration -> https://github.com/JetBrains/gradle-intellij-plugin#plugin-verifier-dsl
// See https://jb.gg/intellij-platform-builds-list for available build versions
ideVersions = ["IU-2021.3"]
// ideVersions = ["IU-2018.1.7", "IU-2019.1.7", "IU-2019.1.4", "IU-2020.1.4", "IU-2021.1.3"]
}

patchPluginXml {
sinceBuild = '181'
}
test {
useJUnitPlatform()
}
4 comments
Comment actions Permalink

thanks to cebron.

this problem is resovled by remove idea vm options "-Djsse.enableSNIExtension=false", the keywords is "SSL error probably caused by disabled SNI" found in idea log file

0
Comment actions Permalink

Thanks for the update, that's an interesting observation.

 

0
Comment actions Permalink

Dreamingnie Where was it defined? Do you remember if you added it yourself?

0

Please sign in to leave a comment.